Bug 55540 - initrd fails with devfs
initrd fails with devfs
Status: CLOSED DUPLICATE of bug 51848
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 14:34 EST by Marek Greško
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-18 15:55:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Greško 2001-11-01 14:34:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Initrd fails to mount real-root-dev when using devfs enabled kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Compile devfs enabled kernel.
2.Create initrd image by mkinitrd, and run lilo with new initrd image.
3.Reboot.
	

Actual Results:  
mkrootdev: mknod failed: 17
mount: cannot mount ext3....

Expected Results:  mount real root filesystem.

Additional info:
Comment 1 Tim Clymo 2001-11-18 15:55:08 EST
I think this is because nash doesn't play nicely with devfs. Mandrake have done
some work on this, and I was able to get it to work by taking their latest
Cooker version of the mkinitrd SRPM (mkinitrd-3.1.6-11_8.1mdk.src.rpm). This
contains some patches for both nash and the /sbin/mkinitrd script which I
applied to the Redhat SRPM (3.2.6-1). A devfs-enabled kernel set to mount /dev
now boots very nicely.

There is another slight problem - once you've got it started, the next thing you
need to do is get it shutdown cleanly and /etc/init.d/halt keeps trying to
unmount /dev. This causes the shutdown to hang since /dev doesn't like being
unmounted. I'm running initscripts-6.40.2-1, and changed the following:
line 29 - 
from: awk '!/(^#|proc|loopfs|autofs|^none|^\/dev\/root| \/ )/ {print $2}'
/proc/mounts
to: awk '!/(^#|devfs|proc|loopfs|autofs|^none|^\/dev\/root| \/ )/ {print $2}'
/proc/mounts
line 181 -
from: umount -a -f
to: umount -a -f -t nodevfs

Perhaps RedHat would like to consider applying the Mandrake fixes for mkinitrd
in their own distribution together with this minor fix to initscripts
Comment 2 Erik Troan 2002-05-21 19:15:45 EDT

*** This bug has been marked as a duplicate of 51848 ***

Note You need to log in before you can comment on or make changes to this bug.