Bug 51848 - mkinitrd doesn't allow devfs anymore
mkinitrd doesn't allow devfs anymore
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
: 55540 62719 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-15 16:01 EDT by Nils Philippsen
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 19:15:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch allowing initrds to work with devfs kernels (3.81 KB, patch)
2001-08-15 16:02 EDT, Nils Philippsen
no flags Details | Diff

  None (edit)
Description Nils Philippsen 2001-08-15 16:01:41 EDT
Initial ramdisks produced with recent mkinitrds will not boot devfs
enabled kernels properly.

The latest version I tried this on is 3.1.6-1.

Steps to Reproduce:
1. Compile kernel with devfs enabled
2. mkinitrd
3. reboot

I'll attach a patch containing two changes:

- nash/mkrootdev() now renames /dev/root (which is already there in
  devfs) prior to making the root device. Perhaps not mkrootdev()ing
  at all is a better way.
- mkinitrd now accepts the --devfs switch which will mount the devfs to
  /dev after pivot_root()ing.
Comment 1 Nils Philippsen 2001-08-15 16:02:43 EDT
Created attachment 28015 [details]
Patch allowing initrds to work with devfs kernels
Comment 2 Nils Philippsen 2001-08-15 16:04:50 EDT
Umm forgot something:

Of course, nash/mkrootdev only renames /dev/root if /dev is a devfs (checks
for existence of /dev/.devfsd).
Comment 3 Erik Troan 2002-05-21 19:12:21 EDT
Could you grab the latest mkinitrd out of CVS and update your patches. Email me
the final patches and I'll integrate them asap. I've marked a couple of bugs
duplicates of this one; they have patches that may or may not help.
Comment 4 Erik Troan 2002-05-21 19:14:02 EDT
*** Bug 62719 has been marked as a duplicate of this bug. ***
Comment 5 Erik Troan 2002-05-21 19:15:38 EDT
*** Bug 55540 has been marked as a duplicate of this bug. ***
Comment 6 Erik Troan 2002-06-19 22:32:45 EDT
I guess you don't want to fix this... As devfs has race conditions, etc
according to everyone I've talked to I'm not going to worry.

Note You need to log in before you can comment on or make changes to this bug.