This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 55545 - Single user mode shell doesn't work right
Single user mode shell doesn't work right
Status: CLOSED DUPLICATE of bug 54865
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 15:30 EST by john.l.villalovos
Modified: 2014-03-16 22:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 08:52:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description john.l.villalovos 2001-11-01 15:30:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
After doing an init 1 command and getting to the shell things do not work 
right.  I can type ls a few times and then start getting errors like: s 
command not found or l command not found.  So it seems like keystrokes are 
being lost by the shell.

Also an error message sometimes prints right before I get to the shell 
prompt.  The message is:
sh: no job control in this shell
sh-2.05#

Then when I hit enter the prompt changes to:
[root@cvs root]#

I have this problem on three systems running Red Hat 7.2.  Two systems 
were upgraded and one was a fresh install.  All systems have all patches 
applied to them that had been released as of 25-Oct-01

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. login as root
2.  type:  init 1
3.  type: ls <enter> a few times and notice error
	

Actual Results:  Error message from shell.  Appears that some keystrokes 
are being lost.

Expected Results:  No keystrokes would be lost and commands would execute.

Additional info:
Comment 1 Bill Nottingham 2001-11-01 15:33:55 EST
Which kernel, exactly, are you running?
Comment 2 john.l.villalovos 2001-11-01 15:36:38 EST
kernel-2.4.9-7.i686 on two of the machines.
kernel-2.4.9-7smp.i686 on one.

Everything works fine unless I go into single user mode.
Comment 3 Andreas J. Bathe 2001-11-06 04:26:53 EST
I realized the same error today: it looks like the directory or environment gets
changed with
two instances (a popd or pushd problem?).

I realized that in comparison with a 7.1 system the 7.2 one does print

sh: no job control in this shell

right before the root prompt.

so here is my screen output:

sh-2.05# ls
anaconda-ks.cfg
[root@neith root]# ls
bin    dev  home  lib              mnt  proc  sbin   usr
boot  etc   initrd   lost+found  opt   root   tmp   var
sh-2.05# ls
anaconda-ks.cfg
[root@neith root]# ls
bin    dev  home  lib              mnt  proc  sbin   usr
boot  etc   initrd   lost+found  opt   root   tmp   var

and so on (we see the two different directories).
Comment 4 Andreas J. Bathe 2001-11-06 04:37:22 EST
downgrading to initscripts and bash from 7.1 doesn't help either;
BTW, kernel here is 2.4.9-13 from errata updates...

take care
Andreas
Comment 5 Andrew Pam 2001-11-06 08:52:26 EST
I have the same problem; it actually appears that two shells are running at the
same time and some input characters go to each of the two shells!  Ewww...
Comment 6 Bill Nottingham 2001-11-06 11:01:29 EST

*** This bug has been marked as a duplicate of 54865 ***
Comment 7 Andreas J. Bathe 2001-11-06 11:54:17 EST
please reopen because # 54865 is assigned to Red Hat Linux - 7.1
Comment 8 Bill Nottingham 2001-11-06 12:22:52 EST
*** Bug 46223 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.