Bug 55551 - /dev/cdrom is not a valid block device
/dev/cdrom is not a valid block device
Status: CLOSED DUPLICATE of bug 55071
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-01 16:14 EST by John Verel
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-12 09:37:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John Verel 2001-11-01 16:14:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; U)

Description of problem:
Upgraded working 7.1 install on Toshiba laptop.  After upgrade, cdrom not 
recognized.  Message above received on attempt to mount.  /etc/fstab had 
valid entry for cdrom.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Download iso images, verity with md5sum.
2.Prepare boot image floppy, as machine will not boot from CDRom
3.Choose upgrade option during installation.

Actual Results:  Could not access CDROM with standard mount command

Expected Results:  Automount, right-click mount option on gnome desktop, 

Additional info:

Workaround/bug:  Problem remedied by logging is as root, typing insmod 
cdrom at command prompt.  cdrom.o is present in module library, but not 
being loaded.  Verified upgrade/workaround twice.

Alternative workaround:  Instead of upgrade choice during install, choose 
laptop install option.  Keep existing partitions and mount points, no 
reformatting.  Reformat and mount swap partition.  Proceed throught 
install normally.  Upon reboot, cdrom working normally, as it was in 7.1.
Comment 1 Arjan van de Ven 2001-11-01 16:21:02 EST
It seems that during an upgrade the kernel modules map doesn't get written
properly in all cases; "depmod -ae" as root fixes that, or an upgrade to the
security errata kernel.
Comment 2 John Verel 2001-11-02 11:38:55 EST
Just looked for above referenced "security errata kernel" on www.redhat.com and 
unclear which package you refer to?  Please advise.  Thanks.
Comment 3 Arjan van de Ven 2001-11-04 17:09:47 EST
is what I ment...
Comment 4 Bill Nottingham 2001-11-08 20:48:19 EST
The bug that cuases the problem with CD-ROMs will be fixed in a future installer
Comment 5 Bill Nottingham 2001-11-12 09:38:23 EST

*** This bug has been marked as a duplicate of 55071 ***

Note You need to log in before you can comment on or make changes to this bug.