Bug 55071 - CD burner won't mount or read CDs; neither will my CDROM.
CD burner won't mount or read CDs; neither will my CDROM.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 55393 55551 55566 55702 55947 56050 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 01:11 EDT by Alex Holder
Modified: 2014-03-16 22:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-27 00:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Holder 2001-10-25 01:11:43 EDT
Description of Problem:
/etc/rc.sysinit is missing a line that it needs in order to handle
"hdx=ide-scsi" boot arguments.   If you only have an ide CD burner it will
probably only make it so that you can't use it to mount and read CDs - but
if you have multiple ide CD drives it will cause them incorrect /dev/cdromx
links and an incorrectly configured /etc/fstab.  The result is that none of
your ide CD drives will work. . . . well actually your cd-burner might
still be able to burn, but you won't be able to mount or read any CD..  

Version-Release number of selected component (if applicable):


How Reproducible:
I was able to reproduce it three times (I reinstalled rh 7.2 three
times).   I haven't upgraded any of the packages that were included on the
7.2 cd.

Steps to Reproduce:
1. Install RH 7.2 on a system with and ide cd burner
2. reboot
3. try to use any of your ide cd drives 

Actual Results:


Expected Results:


Additional Information:
To fix: 
i) add a line that says "modprobe cdrom > /dev/null 2>&1" to
/etc/rc.sysinit just above the line that says "modprobe ide-cd > /dev/null
2>&1".	
 ii) delete the /dev/cdromX symbolic links
iii) delete any cdrom entries in /etc/fstab that refer to "kudzu"
iv) reboot - kudzu will be able to create a valid configuration
Comment 1 Scott Dowdle 2001-10-26 13:11:48 EDT
I have a system with a single IDE CD-ROM reader (NOT a burner) and the CD died
completely after the install giving some error (in the /var/log/messages) about
there being no driver for /dev/hdb.  The kernel did correctly identify the CD
drive upon boot.  Sorry I don't have exact error message but it is on a dualboot
system my wife uses and at home (I'm typing this from work).  My wife reported
later that the CD-ROM drive no longer worked in Windows 98... which is very
suspicious to me.  I know CD-ROM drives die every once in a while of natural
causes but I'm wondering if somehow it is related to this.  I haven't had time
to investigate further.
Comment 2 Joseph Ashby 2001-10-27 00:17:22 EDT
I have seen the same problem but have determined that the
/lib/modules/2.4.7-10/modules.dep was not correct for the loading of the ide-cd
module it should depend on cdrom.o . Was able to correct the problem by
generating a new modules.dep file with a 'depmod -a' command and reset the /dev
links for the cdrom devices.
Comment 3 Bill Nottingham 2001-10-27 02:12:05 EDT
Yes, running 'depmod -ae' should solve the problem; this was an installer bug
that will be fixed in the next release.
Comment 4 Bill Nottingham 2001-11-12 09:36:16 EST
*** Bug 55947 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2001-11-12 09:37:03 EST
*** Bug 55393 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2001-11-12 09:38:17 EST
*** Bug 55551 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2001-11-12 09:38:30 EST
*** Bug 55566 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2001-11-12 09:38:41 EST
*** Bug 55702 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2001-11-12 09:38:50 EST
*** Bug 56050 has been marked as a duplicate of this bug. ***
Comment 10 Phil Lembo 2001-12-22 14:11:23 EST
I had this same problem after installing RH 7.2 on two separate systems, each 
with a different brand CDROM burner. In both cases I determined the problem was 
that the installer failed to include the following line in modules.conf:

alias scsi_hostadapter ide-scsi

Apparently the installer makes all the changes required to support a CDROM 
burner using cdrecord except this one. Simply adding this line and rebooting 
fixed the problem.
Comment 11 luigi viggiano 2002-01-13 12:52:35 EST
I've got the same problem and I spent all the sunday recompiling the kernel and 
checking above solutions. Nothing worked. 
I've got a similar problem also with RH 7.1, and I was hoping that new version 
fixed this.

I solved the problem changing distribution...
Comment 12 Need Real Name 2002-01-15 13:48:03 EST
Interesting...
My system is able to mount data Cds, yet not audio. This has been reproducible 
only 2 times out of 4 installs, without hardware changes.

"Bad superblock on /dev/cdrom", "/dev/cdrom is not a valib block device"
Comment 13 Need Real Name 2002-01-16 12:09:59 EST
I've got a similar proplem,after installing of RH LINUX 7.2,I've found the 
cdrom is not working.only reading files but not viewing the games for 
example.olso the printer is not working,there is no link to the existing 
windows 98 2E .Do i have to reinstall the OS again ? till now i cannot solve 
these proplems.please contact if you know an anser to : 
http://www.housam_mar@hotmail.com . thanks.
Comment 14 Need Real Name 2002-01-30 11:22:25 EST
I have 7.2 with the 2.4.7-10 kernel, RAID controller on SCSI0. Whenever I attempt to mount a CD the system freezes (no mouse movement) and leaves a series of 
messages in /var.log/messages
kernel: SCSI host 1 abort (pid 0) timed out -resetting scsi1, channel 0, lun 0 Test Unit ready 00 00 00 00

I have applied all the fixes mentioned in this bug report ( depmod -ae; editing /etc/rc.sysinit; editing modules.conf) but nothing has changed the system freezing.
Comment 15 Need Real Name 2002-03-15 05:12:47 EST
There is a solution at:

http://www.exocore.com/technologies/linux/rhl71dma/

It worked on my machine and a similar one in my office.

Note You need to log in before you can comment on or make changes to this bug.