Bug 55561 - partitioning error when creating multiple partitions
partitioning error when creating multiple partitions
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 18:12 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 00:38:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from setup (898 bytes, text/plain)
2001-11-01 18:13 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-11-01 18:12:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
error messages
1. Error Creating swap partition
2. Error Creating partition hdb9, message "invalid argument"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Installing RedHat 7.0 using text mode
2. Use DiskDruid
3. Making multiple partitions: / 1500Mb, /usr/local 800Mb, /usr/src 
200Mb, /var 200 Mb <swap> 200Mb
NOTE: hdd is 3,2Gb and is hdb
	

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 104800
fsystem: ext2
self: <fstab.NewtFstab instance at 820a8d8>
msg: Invalid argument
doFormat: 1
errno: 22
device: hdb9
instPath: /mnt/sysimage
mntpoint: /home

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Need Real Name 2001-11-01 18:13:53 EST
Created attachment 36102 [details]
output from setup
Comment 2 Brent Fox 2001-11-02 10:02:31 EST

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.