Bug 55590 - Xconfigurator broken if Kudzu/Mouseconfig change mouse
Summary: Xconfigurator broken if Kudzu/Mouseconfig change mouse
Status: CLOSED DUPLICATE of bug 42225
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-02 15:58 UTC by John Arrowwood
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 15:58:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Arrowwood 2001-11-02 15:58:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I attached a serial mouse to my laptop (which uses a ps/2 mouse 
internally).  When it booted, Kudzu detected the serial mouse and set it 
up for me.  

I found an additional problem not related to this one that prompted me to 
run Xconfigurator.  It complained about a problem with 
the /etc/sysconfig/mouse file and ran Mouseconfig.  After Mouseconfig ran, 
it still wouldn't work.

The error message was that line 5 was unexpected.  Apparently it didn't 
like the line that specifies the device that the mouse is attached to.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Have Kudzu or Mouseconfig change from PS/2 to Serial mouse
2. Run Xconfigurator
3.
	

Actual Results:  Line 5 of /etc/sysconfig/mouse was "unexpected" according 
to Xconfigurator, which caused it to re-run mouseconfig, which didn't help.

Expected Results:  It should have worked, of course... :)

Additional info:

My guess is simply that Mouseconfig and Kudzu were updated to add a line 
that Anaconda doesn't generate and Xconfigurator wasn't updated to handle 
that additional line.

Comment 1 Mike A. Harris 2001-11-02 23:23:42 UTC

*** This bug has been marked as a duplicate of 42225 ***


Note You need to log in before you can comment on or make changes to this bug.