Bug 556134 - Can't create new virtual storage image in /home partition via virt-manager GUI
Can't create new virtual storage image in /home partition via virt-manager GUI
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-16 12:54 EST by Valent Turkovic
Modified: 2010-01-20 07:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-18 08:20:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
New VM (32.19 KB, image/png)
2010-01-16 13:18 EST, Valent Turkovic
no flags Details
Locate or create storage volume (19.49 KB, image/png)
2010-01-16 13:18 EST, Valent Turkovic
no flags Details
Add a Storage Volume (41.56 KB, image/png)
2010-01-16 13:19 EST, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2010-01-16 12:54:57 EST
Description of problem:
I wanted to install new linux virtual machine and as with VirtualBox wanted to keep virtual storage image in users home directory.

virt-manager only offers to use my / partition and that is now acceptable because I use it only for Fedora and usually format it on every new release, and it is too small, only 10GB. Plenty of room for Fedora but not for additional virtual images.

I have a large /home partition where I keep all my user files and also my virtual machines in VirtualBox.

virt-manager doesn't support creating new storage image in /home partition, please change that.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2010-01-16 13:18:16 EST
Created attachment 384832 [details]
New VM
Comment 2 Valent Turkovic 2010-01-16 13:18:49 EST
Created attachment 384833 [details]
Locate or create storage volume
Comment 3 Valent Turkovic 2010-01-16 13:19:15 EST
Created attachment 384834 [details]
Add a Storage Volume
Comment 4 Lubomir Rintel 2010-01-18 08:20:20 EST
Grow your /var. According to FHS it's the correct place for variable runtime data and SELinux wouldn't allow libvirtd access your home anyway.
Comment 5 Valent Turkovic 2010-01-18 10:45:55 EST
I don't wan't to store virtual images in /var but in /home as I do with VirtualBox and all other Virtualization apps. I have SELinux disabled and still pressing NEW IMAGE button doesn't present option to choose where to save virtual image file.

please view this video: http://dl.dropbox.com/u/184632/virt-manager.ogg
Comment 6 Valent Turkovic 2010-01-18 10:59:31 EST
or this link: http://www.youtube.com/watch?v=cqGOhZC_WXQ
Comment 7 Justin M. Forbes 2010-01-19 09:49:44 EST
Then you need to set up a new storage pool in /home.  This is done before creating a new virtual machine.  In virt-manager:

Open the host details for 'localhost (qemu)'
Click the 'storage' tab
click the '+' on the bottom left side to add a pool

You can add a storage pool to use with virtual machines in this way, and can create volumes in the new pool.
Comment 8 Valent Turkovic 2010-01-20 07:59:12 EST
Thank you Justin for clarification, this helped a lot! This isn't for me as a new user of virt-manager and this functionality would be somehow more emphasized in UI of popup window when users try to add new storage image.

I thought about these issues and posted two RFEs, please comment on them:
https://bugzilla.redhat.com/show_bug.cgi?id=557103
https://bugzilla.redhat.com/show_bug.cgi?id=557107

Note You need to log in before you can comment on or make changes to this bug.