Bug 557103 - Add qemu:///session option to 'add connection' dialog
Add qemu:///session option to 'add connection' dialog
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
: Reopened
: 559005 845604 892765 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-20 07:42 EST by Valent Turkovic
Modified: 2014-02-01 19:46 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-01 19:46:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2010-01-20 07:42:22 EST
Description of problem:
After reporting bug: https://bugzilla.redhat.com/show_bug.cgi?id=556134 and discussing I saw as a new user to virt-manager some issues that more seasoned users probably don't notice and take for granted.

Please make storage pools more user friendly via renaming current storage pool from "default" to "/var (default)".

Also please add second storage pool that is located in /home partition.

If I wasn't clear enough because of my English writing skills please tell me which part needs more clarification.

Cheers from Croatia!

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Charles R. Anderson 2010-02-18 17:33:21 EST
BTW, Fedora 12 selinux includes /home/*/VirtualMachines as a correctly labeled place to put virtual images.
Comment 2 Cole Robinson 2010-05-10 16:05:35 EDT
Using a storage pool in /home isn't really a good default option for the current virt configuration, since the VMs are run by the system wide libvirtd instance. It would be equivalent to default sharing out httpd web pages from a regular users home directory.

The proper solution here is to move towards using qemu:///session for default desktop virt. With qemu:///session, libvirtd is run as the regular user, which avoids all sorts of integration issues like file/media permissions, sound not working, etc. , but comes with its own pain points like networking configuration.

Might as well use this bug to track that work.
Comment 3 Cole Robinson 2010-05-10 16:08:19 EDT
*** Bug 559005 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2012-01-18 11:55:04 EST
Moving to upstream tracker
Comment 5 Cole Robinson 2012-10-14 22:32:37 EDT
Now that gnome-boxes exists and uses qemu:///session, virt-manager might not be destined to default to qemu:///session. I'll have to give it some thought. But support should definitely be improved, and step one at least is exposing system vs. session in the UI.
Comment 6 Cole Robinson 2012-10-14 22:34:46 EDT
*** Bug 845604 has been marked as a duplicate of this bug. ***
Comment 7 Cole Robinson 2013-04-01 06:04:23 EDT
*** Bug 892765 has been marked as a duplicate of this bug. ***
Comment 8 Cole Robinson 2013-10-01 17:48:11 EDT
Eh, I changed my mind, I don't think there's much to do here. If people have specific suggestions we can try to address them but we aren't ever going to be using qemu:///session I don't think
Comment 9 Marc-Andre Lureau 2013-10-02 06:46:36 EDT
It mostly works for me, as long as I do simple things (create a VM, start/stop, no network changes). So it would be nice if this would be easier to setup. For instance, have "Add Connection" propose qemu://session. It is not broken enough for me to invest time in fixing it. It is just a bit unconfortable to have to explain to other people how to workaround this (quite unnecessary) virt-manager limitation.
Comment 10 Cole Robinson 2013-10-02 08:56:38 EDT
(In reply to Marc-Andre Lureau from comment #9)
> It mostly works for me, as long as I do simple things (create a VM,
> start/stop, no network changes). So it would be nice if this would be easier
> to setup. For instance, have "Add Connection" propose qemu://session. It is
> not broken enough for me to invest time in fixing it. It is just a bit
> unconfortable to have to explain to other people how to workaround this
> (quite unnecessary) virt-manager limitation.

Oh, I forgot we talked about this before :)

There is reasoning behind it: the differences between session and system are simultaneously huge and subtle. virt-manager mostly works for session, yes. but if someone is expecting 'normal' virt-manager VM behavior, suddenly things are different: networking, various root requiring device options, 'where all my pre-existing vms (that are actually on qemu:///system), etc. We've already had quite smart people complaining about each of those things, and that was with them explictly opting in by passing qemu:///session on the command line. Sticking it in the UI adds an extra element of truly clueless people selecting it without knowing the repercussions and hey why can't my VMs do what your VMs do, or bug reports that get 20 comments deep before I realize they are using session.

That said, I guess if we added a 'Use session instance' checkbox to the 'add connection' dialog, only visible if hv == qemu, that when selected added a little warning box to the dialog concisely saying 'some things won't work, limited networking mode' then that's actually more helpful then the current state since people will be on the look out for caveats. Reopening
Comment 11 Marc-Andre Lureau 2013-10-02 09:04:00 EDT
that sounds reasonable to me too.
Comment 14 Cole Robinson 2014-02-01 19:46:02 EST
This is upstream now: rather than a checkbox, the hypervisor combo box has an explicit 'qemu user session' option that shows the warning

Note You need to log in before you can comment on or make changes to this bug.