This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 55621 - %post scriptlet fails with --excludedocs
%post scriptlet fails with --excludedocs
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: grep (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks: 54961 55286
  Show dependency treegraph
 
Reported: 2001-11-02 18:22 EST by Tim Waugh
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-08 05:42:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2001-11-02 18:22:21 EST
Description of Problem:
When installing grep with --excludedocs the %post scriptlet fails because 
the info files are not installed.

Version-Release number of selected component (if applicable):
2.5-0.f.2

How Reproducible:
100%

Steps to Reproduce:
1. rpm -e grep
2. rpm -ivh grep* --excludedocs

Additional Information:
The %post scriptlet should use '|| :' to fix this.
Comment 1 Bill Nottingham 2001-11-05 10:25:29 EST
Alternatively, perhaps info pages shouldn't be marked as %doc.
Comment 2 Tim Waugh 2001-11-05 10:28:20 EST
The info pages are not marked as %doc.  However, rpm decides not to install 
them anyway if you use --excludedocs.
Comment 3 Tim Waugh 2001-11-09 06:51:30 EST
(This is fixed in 0.f.3)

Note You need to log in before you can comment on or make changes to this bug.