Bug 556341 - [abrt] crash in tigervnc-1.0.0-3.fc12
[abrt] crash in tigervnc-1.0.0-3.fc12
Status: CLOSED DUPLICATE of bug 541569
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
abrt_hash:6f9a56bd007e44c65f5cf32222d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-17 20:17 EST by Alessandro Suardi
Modified: 2013-04-30 19:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-18 07:59:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (71.46 KB, text/plain)
2010-01-17 20:18 EST, Alessandro Suardi
no flags Details

  None (edit)
Description Alessandro Suardi 2010-01-17 20:17:39 EST
abrt 1.0.3 detected a crash.

How to reproduce
-----
1. Acer Aspire Revo running VNC server on Fedora 11 x86_64, Transmission hogging up wireless router bandwidth
2. connect from Dell E6300 running Fedora 12 via VNC viewer on a wireless link (with the Broadcom Linux STA driver)
3. as bandwidth wobbles and VNC viewer adjusts connection quality, sooner or later the viewer will try to get back to 24bpp and crash

Comment: Happened when the client was Fedora 11 as well.
Attached file: backtrace
cmdline: vncviewer torrent:2
component: tigervnc
executable: /usr/bin/vncviewer
kernel: 2.6.33-rc4-git1
package: tigervnc-1.0.0-3.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
Comment 1 Alessandro Suardi 2010-01-17 20:18:00 EST
Created attachment 384986 [details]
File: backtrace
Comment 2 Alessandro Suardi 2010-01-17 20:26:20 EST
Sorry, I meant get back to 32bpp and crash - like this:

Mon Jan 18 02:21:09 2010
 CConn:       Throughput 251 kbit/s - full color is now disabled
 CConn:       Using pixel format depth 8 (8bpp) color-map

Mon Jan 18 02:21:12 2010
 CConn:       Throughput 325 kbit/s - full color is now enabled
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888

Mon Jan 18 02:21:43 2010
 CConn:       Throughput 250 kbit/s - full color is now disabled

Mon Jan 18 02:21:44 2010
 CConn:       Using pixel format depth 8 (8bpp) color-map
 CConn:       Throughput 271 kbit/s - full color is now enabled

Mon Jan 18 02:21:45 2010
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
Segmentation fault


/var/log/messages says this:

Jan 18 02:21:46 duff kernel: vncviewer[4399]: segfault at 10 ip 0000000000436df8 sp 00007fff4e317190 error 4 in vncviewer[400000+81000]


Note that the wireless link is far from perfect, and does have both
 TX and RX errors.

[asuardi@duff ~]$ ip -s link show eth1
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:23:4d:b3:53:8a brd ff:ff:ff:ff:ff:ff
    RX: bytes  packets  errors  dropped overrun mcast   
    956532930  805895   265     0       0       0      
    TX: bytes  packets  errors  dropped carrier collsns 
    40788367   474708   4823    0       0       0
Comment 3 Adam Tkac 2010-01-18 07:59:07 EST

*** This bug has been marked as a duplicate of bug 541569 ***

Note You need to log in before you can comment on or make changes to this bug.