Bug 541569 - [abrt] crash detected in tigervnc-1.0.0-3.fc12
[abrt] crash detected in tigervnc-1.0.0-3.fc12
Status: CLOSED DUPLICATE of bug 551262
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
abrt_hash:74f8dad9915a3b3016450bd77c7...
:
: 556341 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-26 06:26 EST by Alan
Modified: 2013-04-30 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-04 10:32:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (73.21 KB, text/plain)
2009-11-26 06:26 EST, Alan
no flags Details

  None (edit)
Description Alan 2009-11-26 06:26:19 EST
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. Erro ao fechar o TigerVNC
2.
3.


Attached file: backtrace
cmdline: /usr/bin/vncviewer
component: tigervnc
executable: /usr/bin/vncviewer
kernel: 2.6.31.6-134.fc12.x86_64
package: tigervnc-1.0.0-3.fc12
rating: 4
reason: Process was terminated by signal 11
Comment 1 Alan 2009-11-26 06:26:24 EST
Created attachment 373971 [details]
File: backtrace
Comment 2 Rajeesh 2009-11-29 04:36:25 EST
Here's a "me too" with the same backtrace, but with tigervnc-1.0.0-1.fc12.i686.
This happens very frequently.
Comment 3 Rajeesh 2010-01-16 08:58:29 EST
I can now reproduce the crash reliably. Click "Options" and change any default settings. I chose to uncheck "Auto select" and selected "Medium" from the "Encoding and Color Level". Click "OK" and tigervnc crashes. The GDB backtrace goes like this:

Starting program: /usr/bin/vncviewer 

TigerVNC Viewer for X version 1.0.0 - built Oct 26 2009 10:57:15
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 TightVNC Group
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See http://www.tigervnc.org for information on TigerVNC.
warning: .dynamic section for "/usr/lib/libXfixes.so.3" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations

Program received signal SIGSEGV, Segmentation fault.
0x08052fe8 in XChangeWindowAttributes ()
(gdb) bt
#0  0x08052fe8 in XChangeWindowAttributes ()
#1  0x08058b42 in ?? ()
#2  0x08060e46 in ?? ()
#3  0x0806131b in ?? ()
#4  0x08058dab in ?? ()
#5  0x08056baa in XChangeWindowAttributes ()
#6  0x0805e562 in ?? ()
#7  0x008efbb6 in __libc_start_main () from /lib/libc.so.6
#8  0x0804eaf1 in XChangeWindowAttributes ()
(gdb)
Comment 4 Adam Tkac 2010-01-18 07:59:07 EST
*** Bug 556341 has been marked as a duplicate of this bug. ***
Comment 5 Jan Görig 2010-03-04 10:32:53 EST

*** This bug has been marked as a duplicate of bug 551262 ***

Note You need to log in before you can comment on or make changes to this bug.