Bug 55637 - undefined references/bookmarks for elements inside tables
undefined references/bookmarks for elements inside tables
Status: CLOSED CANTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: jadetex (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-03 10:27 EST by rudi
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 15:34:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase (579 bytes, text/sgml)
2001-11-08 13:03 EST, rudi
no flags Details
DocBook test case (493 bytes, text/plain)
2001-11-09 05:52 EST, Tim Waugh
no flags Details
FOT test case (13.12 KB, text/plain)
2001-11-09 05:53 EST, Tim Waugh
no flags Details

  None (edit)
Description rudi 2001-11-03 10:27:30 EST
Description of Problem:
(Already reported on Sourceforge - bug #452540)

I'm using Norman Walsh's stylesheets and every indexterm
defined in a entry in a table does NOT get its page number
resolved in the index.

E.g. I get

LaTeX Warning: Reference `IDX-ICONTROL' on page 211
undefined on input line 89746.

If I inspect the .tex file, the label seems to be defined (at least
apparently):

$ grep -15 IDX-ICONTROL *tex
auisg.tex-\TableCell%
auisg.tex-{\def\CellRowAlignment%
auisg.tex-{start}\def\CellBeforeRowMargin%
auisg.tex-{3\p@}\def\CellAfterRowMargin%
auisg.tex-{3\p@}\def\CellBeforeColumnMargin%
auisg.tex-{0\p@}\def\CellAfterColumnMargin%
auisg.tex-{3\p@}\def\StartIndent%
auisg.tex-{2\p@}\def\StartIndentFactor%
auisg.tex-{0}\def\EndIndent%
auisg.tex-{2\p@}\def\EndIndentFactor%
auisg.tex-{0}}\Par%
auisg.tex-{\def\fFamName{Times-New-Roman}\def\fWeight%
auisg.tex-{medium}\def\Quadding%
auisg.tex-{start}}      \Node%
auisg.tex-{\def\Label%
auisg.tex:{IDX-ICONTROL}}\Seq%
auisg.tex-{}\endSeq{}\endNode{}
auisg.tex-      IControl\endPar{}\endTableCell{}%
auisg.tex-}%
auisg.tex-&\TeXTableCell{1}{T{0\p@}{347\p@}{3\p@}}%
auisg.tex-{%
auisg.tex-\TableCell%
auisg.tex-{\def\CellRowAlignment%
auisg.tex-{start}\def\CellBeforeRowMargin%
auisg.tex-{3\p@}\def\CellAfterRowMargin%
auisg.tex-{3\p@}\def\CellBeforeColumnMargin%
auisg.tex-{0\p@}\def\CellAfterColumnMargin%
auisg.tex-{3\p@}\def\StartIndent%
auisg.tex-{2\p@}\def\StartIndentFactor%
auisg.tex-{0}\def\EndIndent%
auisg.tex-{2\p@}\def\EndIndentFactor%
--
auisg.tex-{\def\Label%
auisg.tex-{X287}}\endNode{}\endLink{}\endNode{}
auisg.tex-  \endPar{}\endNode{}\Node%
auisg.tex-{\def\Element%
auisg.tex-{8158}}\Par%
auisg.tex-{\def\fSize%
auisg.tex-{9\p@}\def\StartIndent%
auisg.tex-{58\p@}\def\StartIndentFactor%
auisg.tex-{0}}preferences editor,
auisg.tex-    \Node%
auisg.tex-{\def\Element%
auisg.tex-{8159}}\Seq%
auisg.tex-{\def\fWeight%
auisg.tex-{bold}}\Link%
auisg.tex-{\def\Label%
auisg.tex:{IDX-ICONTROL}}\Node%
auisg.tex-{\def\Label%
auisg.tex:{IDX-ICONTROL}\def\ProcessingMode%
auisg.tex-{toc-page-number-mode}}\insertCurrentNodePageNumber%
auisg.tex-{\def\Label%
auisg.tex:{IDX-ICONTROL}}\endNode{}\endLink{}\endSeq{}\endNode{}
auisg.tex-  \endPar{}\endNode{}\endNode{}\Node%
auisg.tex-{\def\Element%
auisg.tex-{8161}}\Node%
auisg.tex-{\def\Element%
auisg.tex-{8162}}\Par%
auisg.tex-{\def\fSize%
auisg.tex-{9\p@}}IDs,
auisg.tex-    \Node%
auisg.tex-{\def\Element%
auisg.tex-{8163}}\Link%
auisg.tex-{\def\Label%
auisg.tex-{X289}}\Node%
auisg.tex-{\def\Label%
auisg.tex-{X289}\def\ProcessingMode%
auisg.tex-{toc-page-number-mode}}\insertCurrentNodePageNumber%

That's why I'm reporting this as a bug in jadetex, not db-style-dsssl.
The labels never appear in the aux file, no matter how many times
I run jadetex. The above is all I can submit (the whole .tex file is
a couple of megabytes), but see below for a simple testcase.


Version-Release number of selected component (if applicable):
All, AFAICS.

How Reproducible:
Always

Steps to Reproduce:
1. See below
2. 
3. 

Actual Results:
"Undefined reference" errors in jadetex output

Expected Results:
Correct hyperlinks and references in final output.

Additional Information:
	
Peter Eisentraut (petere78@sourceforge) adds:

Just having encountered the same problem, I just wanted to
add some of my own obervations. This is not really dependent
on indexterms.  Any link will do.  Process the following
document with DSSSL stylesheets 1.70 or so and JadeTeX
3.10.  I agree with the original posters assessment that the
.tex file looks correct, all the targets seem to be
defined.  Note also that if the link is to the <table>
element, everything works correctly.

<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook V3.1//EN">
<book>
 <title>My Book</title>

 <chapter>
  <title>First Chapter</title>

  <para>
   See also <link linkend="foo">elsewhere</link>
  </para>
 </chapter>

 <chapter>
  <title>Second Chapter</title>

  <table>
   <title>Some Table</title>
   <tgroup cols=2>
    <tbody>
     <row>
      <entry id="foo">one</entry>
      <entry>two</entry>
     </row>
    </tbody>
   </tgroup>
  </table>
 </chapter>
</book>
Comment 1 Tim Waugh 2001-11-06 05:00:08 EST
The SGML test case seems to be a different problem to the one that your 
auisg.tex file is exhibiting.  For the SGML test case, I don't see the 
reference defined in the tex output. (This seems to be an openjade bug.)

There is another bug (sf bug #443192) that hampers test cases containing an 
index.  With jadetex-3.11-3 (yet to be pushed to rawhide) this is worked 
around; also it is not present in jadetex < 3.11.

It would be helpful if you could find:

- a minimal test case that exhibits the bug whereby correct TeX output from 
openjade gives incorrect DVI output from jadetex

- which package versions you are using for jadetex, openjade and 
docbook-style-dsssl.

Thanks.
Comment 2 rudi 2001-11-08 13:03:58 EST
Created attachment 36901 [details]
Testcase
Comment 3 Tim Waugh 2001-11-08 13:10:03 EST
This test case has no index, and the DVI seems fine.  Did you mean to have 
index as 'IGNORE'?
Comment 4 rudi 2001-11-08 13:18:02 EST
This is how to reproduce the bug using the testcase I attached.

Generate the index using the HTML backend:

openjade -t sgml -i html -V html-index -d
/usr/share/sgml/docbook/utils-0.6.9/docbook-utils.dsl#html indexbug.sgml
Create the SGML markup for the index:

collateindex.pl -p -o term.idx HTML.index(omitting -p doesn't seem to make any
difference)

Generate the .tex file, this time setting "index" so that the
index markup in term.idx gets included:

openjade -t tex -i print -V tex-backend -i index -d
/usr/share/sgml/docbook/utils-0.6.9/docbook-utils.dsl#print indexbug.sgml
Now run either pdfjadetex or jadetex on indexbug.tex. You should get undefined
references, although IDX-ICONTROL seems to be defined if you look at the TeX
source. There's also a note in the index if you open the PDF file, with the
path to the HTML link target. I had never seen such behaviour before.

I'm using the very latest packages from RawHide:

$ rpm -q openjade docbook-style-dsssl docbook-utils docbook-utils-pdf jadetex tetex
openjade-1.3-21
docbook-style-dsssl-1.73-3
docbook-utils-0.6.9-6
docbook-utils-pdf-0.6.9-6
jadetex-3.11-3
tetex-1.0.7-35
Comment 5 Tim Waugh 2001-11-08 13:24:25 EST
Excellent, thanks.
Comment 6 rudi 2001-11-08 13:29:58 EST
Yes, I always have the index ignored by default, to prevent
"chicken and egg" problems when rebuilding everything from
scratch. After the index markup has been created, "-i index"
is always passed to openjade.

This saves one attachment ;) and also makes sure there can't be
problems due to inconsistencies between the index and the rest
of the document.
Comment 7 Tim Waugh 2001-11-09 05:52:06 EST
I merged the index and the document together to create a single file test 
case.  I'll attach the DocBook and the FOT here.
Comment 8 Tim Waugh 2001-11-09 05:52:46 EST
Created attachment 37006 [details]
DocBook test case
Comment 9 Tim Waugh 2001-11-09 05:53:30 EST
Created attachment 37007 [details]
FOT test case
Comment 10 Bill Nottingham 2006-08-07 21:52:10 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 11 Bill Nottingham 2006-10-18 15:34:06 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.