Bug 5565 - gedit crashed when started with an argument
gedit crashed when started with an argument
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gedit (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
: 5587 5856 6102 6333 6525 8387 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-05 02:34 EDT by Trond Eivind Glomsrød
Modified: 2013-04-02 00:13 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 18:02:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trond Eivind Glomsrød 1999-10-05 02:34:37 EDT
If gedit is started with a file as an argument (eg. "gedit
/etc/sendmail.cf"), it exits immediately with a core dump
(after the gnome application crash dialog)
Comment 1 Michael Fulbright 1999-10-20 12:27:59 EDT
*** Bug 5587 has been marked as a duplicate of this bug. ***

When opening a text file from gmc (in this case fstab)
right-clicking on it & choosing open with gedit the app
(gedit) crashes with a segmentation fault. It does not crash
if you open gedit first then load the text file into it.

backtrace

0x403da4e1 in __kill () from /lib/libc.so.6

this is an annoying but minor bug
Comment 2 Michael Fulbright 1999-10-20 12:54:59 EDT
*** Bug 5856 has been marked as a duplicate of this bug. ***

gEdit crashes everytime you try to start it
Comment 3 Michael Fulbright 1999-10-20 15:05:59 EDT
*** Bug 6102 has been marked as a duplicate of this bug. ***

Giving gedit a file name on the command line causes gedit to
crash. Invoking gedit, then opening the file works.

I've reproduced this both on a machine upgraded from 6.0 and
a machine freshly installed.
Comment 4 Michael Fulbright 1999-10-26 11:15:59 EDT
*** Bug 6333 has been marked as a duplicate of this bug. ***

when the default editor is gedit the edit voice of the
right click menu of gmc causes a segmentation fault of gedit

------- Additional Comments From wowbagger@sktc.net  10/25/99 14:46 -------
This sounds very much like the bug I submitted, #5565
Comment 5 Michael Fulbright 1999-11-02 11:36:59 EST
*** Bug 6525 has been marked as a duplicate of this bug. ***

I have been able to make GEdit crash on my fresh RH 6.1
install by doing various things.  I had no problems under RH
6.0.  All crashes are Seg Faults and core is dumped.

1) Opened a file, copied some text, pasted the text, opened
the search dialog, canceled the search operation, hit the
print button, hit OK and it crashes.

2) Checking some options in the settings menu causes GEdit
to crash.

3) Opening the Settings->Preferences dialog and making any
change followed by either Apply or OK will cause GEdit to
crash.

Running:

Dell Dimension XPS R400
Intel PII 400Mhz
128MB RAM
Comment 6 Trond Eivind Glomsrød 1999-11-22 07:27:59 EST
Both starting gedit with an initial argument and opening a file with gedit from
within gmc seems to work with gedit 0.6.0
Comment 7 Michael Fulbright 2000-01-12 11:00:59 EST
*** Bug 8387 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Blandford 2000-02-03 18:02:59 EST
This has been fixed in October GNOME.

Note You need to log in before you can comment on or make changes to this bug.