Bug 55657 - Install fails to properly detect disk volume on 3ware Escalade IDE/ATA PCI RAID controller.
Install fails to properly detect disk volume on 3ware Escalade IDE/ATA PCI RA...
Status: CLOSED DUPLICATE of bug 51214
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-03 22:59 EST by Eric George
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-03 22:59:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric George 2001-11-03 22:59:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
I had a similar problem installing RedHat 7.1.  See Bugzilla #41790
The actions I took to resolv it then aren't working now.

Here goes...
I boot from the CD and go through the menus.  When I get to the
installation type I choose custom.  Then, on the disk partitioning screen,
I choose disk druid.  When I pick next, I get a window popping up that says 

"The partition table on device SDA was unreadable.  To create a new
partition, it must be initialized, causing the loss of ALL DATA on this
drive.  Would you like to initialize this drive?"

I click yes, and get the following pop-up:

"Error opening /tmp/sda: No such device or address"

Clicking <retry> doesn't help.

I get identical behavior if I choose fdisk instead of disk druid.

sda is the RAID 1 volume on a 3ware Escalade 6200
It was previously partitoned & formatted ext2 and fat32 by RedHat 7.1. 
Everything appeared to be working fine when I started the RH7.2 install.

As I said, I had a similar problem installing 7.1, so I tried what I did
there:

1. hit <ctrl><f2> to get to a command prompt
2. mknod sda
3. fdisk sda

Now I can see the disk OK
I tried deleting the partitions, no change.
Then I rebooted and tried creating one big partition.  Again, no change.

If I boot from the 7.1 install CD, everything works fine.  I can see sda
properly without going into fdisk during the install.

I have also tried expert mode install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt to install
2.
3.
	

Actual Results:  As described above

Expected Results:  Proper detection of sda, and continued install

Additional info:

Hardware Config:
IWill KK266
AMD ThunderBird-C 1200 MHz
384 MB PC133 RAM
3ware Escalade 6200 IDE RAID controller
2x20 GB Maxtor 7200 RPM drives
GeForce2 MX video
Ensoniq 1371 based PCI sound card.
Another IDE drive on hda (disk druid does find this with no problems)
CD, CDRW, Zip on onboard IDE controllers.
Comment 1 Jeremy Katz 2001-11-04 00:41:13 EST
Please see http://www.redhat.com/support/errata/RHBA-2001-131.html for more
information on the update disk to fix this problem

*** This bug has been marked as a duplicate of 51214 ***
Comment 2 Eric George 2001-11-04 12:31:09 EST
Ok, thanks.  I'll try it.
FWIW, I did search on 3ware before posting this, but didn't turn anything up
(which is strange considering that I had posted a bug on 7.1 also).
Eric

Note You need to log in before you can comment on or make changes to this bug.