Bug 55670 - kickstart: part --onpart --noformat still requires --size for existing partitions
kickstart: part --onpart --noformat still requires --size for existing partit...
Status: CLOSED DUPLICATE of bug 55373
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-04 09:29 EST by Zenon Mousmoulas
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-04 09:29:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Mousmoulas 2001-11-04 09:29:48 EST
Description of problem:
In a kickstart configuration file, using the "part" (partition) 
directive, it seems it is always required to use the --size parameter for 
this directive, even on existing partitions (declared with --onpart) that 
are marked not to be formatted (--noformat). This is either a bug in the 
kickstart configuration parsing code of anaconda or it is just not 
documented right in the RHL Official Customization Guide; nowhere in this 
guide is it implied or noted that a "part" directive requires the use of 
the "--size" directive. In my opinion, it is therefore normal to assume 
that one does not need to use the --size parameter for an existing 
partition that will not be created and formatted by anaconda.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Write a ks.cfg file with a directive: "part /mount/point --onpart 
hdc1 --noformat -fstype vfat"
2. Install RHL: e.g. boot from RHL 7.2 CD1 with ks.cfg on a floppy and 
type linux ks=floppy
3. Notice anaconda exits abnormally with a final message: "partition 
command requires a size specification".
4. Edit ks.cfg and appent "--size=1" to the line in step 1.
5. Repeat the procedure in step 2.
6. Notice anaconda does not stop now.

Actual Results:  Anaconda terminates abnormally before the installation 
procedure even begins.

Expected Results:  Anaconda should install right using the kickstart 
configuration from ks.cfg.

Additional info:

Kickstart documentation (part of RHL Official Customization Guide) is not 
clear at several points. Most specifically, the two most noticeable 
issues are:
A. It is not always clear what the right syntax for directive parameters 
that accept arguments is, i.e. if 
directive --parameter argument
is right or if
directive --parameter=argument
is right. From experience, it usually does not make a difference, but 
using the "=" syntax is cleaner. But I have no clue the scripting 
language that anaconda uses (python) does process these syntax formats 
different.
B. The documentation should include syntactical examples for every 
directive and parameter explained. It should also be explicitly noted 
when a directive requires at a minimum some parameters, which parameters 
are required to be used together and which parameters conflict with each 
other and should not be used together. There are some notes about such 
issues (e.g. see the part/partition directive documentation) but there 
are many more missing (e.g. see the issue described in this bug under 
Description).
Comment 1 Jeremy Katz 2001-11-05 18:08:37 EST

*** This bug has been marked as a duplicate of 55373 ***

Note You need to log in before you can comment on or make changes to this bug.