Bug 55373 - Install kickstart with --onpart
Install kickstart with --onpart
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 55670 56043 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 10:59 EST by derrien
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 15:25:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description derrien 2001-10-30 10:59:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
From my kickstart file :
...
#zerombr
#clearpart --initlabel msdos --
#part / --size 4000
#part swap --size 512
#part /local --size 100 --grow
part / --onpart hda2 --fstype ext3
part swap --onpart hda5
install
...

Message from installer :

File "/usr/loib/anaconda/kickstar.py", line 746, in define partition
raise Value Error , "partition command requires a size specification"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create un kickstart file with --onpart
2. Install
3.
	

Additional info:
Comment 1 Michael Fulbright 2001-10-30 14:52:57 EST
This is a known issue. Just assign a size to the partition and it will work ok.
The size will be ignored for partitions with a '--onpart' specification, but it
is required by the parser of the ks.cfg.

Let me know if this works around the problem.
Comment 2 derrien 2001-10-31 07:27:24 EST
size with --onpart works around the problem. Thanks.
Comment 3 Brent Fox 2001-10-31 16:07:52 EST
*** Bug 55469 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2001-11-05 18:08:31 EST
*** Bug 55670 has been marked as a duplicate of this bug. ***
Comment 5 Brent Fox 2001-11-08 11:24:46 EST
msf, has this been fixed in Rawhide?
Comment 6 Brent Fox 2001-11-11 23:31:03 EST
*** Bug 56043 has been marked as a duplicate of this bug. ***
Comment 7 Joseph Kotran 2001-12-21 20:28:46 EST
Hello,

	This bug was not fixed for 7.2.  Please issue an errata notice so that 
sys admins can have a heads up.  I wasted too much time trolling newsgroups 
and Red Hat's non beta discussion groups.

				Thank you,

				Joe Kotran
Comment 8 Jeremy Katz 2002-01-23 16:51:48 EST
Fixed by errata released yesterday

Note You need to log in before you can comment on or make changes to this bug.