This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 55683 - hwclock needs --directisa on ASUS motherboards.
hwclock needs --directisa on ASUS motherboards.
Status: CLOSED DUPLICATE of bug 34374
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-04 16:42 EST by Idcmp
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 03:13:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Idcmp 2001-11-04 16:42:46 EST
There's a known (on the net) issue with hwclock accessing /dev/rtc causing
hangs on ASUS motherboards (A7V133 in this case).  To get around this,
CLOCKFLAGS needs --directisa added to it for those motherboards.  hwclock
is called both in /etc/rc.d/sysinit and /etc/rc0.d/S01halt ..     Without
it, the system will seemingly hang on startup or shutdown for no reason..

I've logged this against util-linux as that's where hwclock is from, but
this may be an issue with /dev/rtc in the kernel..
Comment 1 Elliot Lee 2002-01-04 14:58:03 EST
There's no way to reasonably know that this flag needs adding... I will ask the
kernel people if this is a problem of theirs (which I would guess it is) -
otherwise, you are probably stuck with just editing initscripts manually :(
Comment 2 Eric Malouin 2002-02-27 23:21:36 EST
I had the same problem.  It occurred every time I did a normal shutdown (not
reboot).

To fix it, I replaced hwclock with the latest version and it seem to fix the
problem...

I am now using hwclock 2.15  and I don't have this problem anymore...
Comment 3 Elliot Lee 2002-03-27 10:40:14 EST

*** This bug has been marked as a duplicate of 34374 ***

Note You need to log in before you can comment on or make changes to this bug.