Bug 34374 - hwclock cannot access the cmos clock
hwclock cannot access the cmos clock
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
: 55683 62094 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-02 16:20 EDT by Steve Chang
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 08:31:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Chang 2001-04-02 16:20:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; COM+ 
1.0.2204)


On two out of three of our Tyan S2510 and four of eight SuperMicro P6DGE 
dual PIII motherboards, hwclock hangs when run, including at boot. Ctrl-C 
will abort this step, but then it gets hung up indefinitely again when 
starting up the system logger. Ctrl-\ will abort this step and allows the 
system to boot completely, but the system clock is, of course, not 
initialized. 

Reproducible: Sometimes
Steps to Reproduce:
1. attempt to boot.
Comment 1 S P Arif Sahari Wibowo 2001-07-02 20:11:18 EDT
I second that.

I have a system with Asus A7V133 w/audio, Athlon 850 Mhz, Diamond S540 (Savage4).
Honestly I think it might be hardware problem, but the CMOS clock seems fine
from the BIOS menu. Anybody have an idea on what is the cause?
It was Ok for few days, and then this problem started. I got around it by
renaming hwclock and put an empty file there.
Comment 2 Elliot Lee 2001-07-18 13:25:17 EDT
Hmm, sounds almost like a kernel+hardware problem (since I believe /dev/rtc is
used for clock access...). Not sure how to investigate yet, though.
Comment 3 Joe Orton 2002-01-17 08:15:50 EST
I have a similar A7V-based system which exhibits this problem too (using a stock
7.2 install, and also using the errata kernel). The hwclock invocation in
init.d/halt also hangs. A workaround for both problems is to add

CLOCKFLAGS="--directisa" 

to /etc/sysconfig/hwclock

once you've managed to boot.  According to http://freshmeat.net/releases/41231/,
there is a version of hwclock which also works around this problem:

"This release avoids the hang (usually a boot time hang) on machines with broken
rtc drivers by timing out after 2 seconds waiting for the clock interrupt, then
falling back to a non-interrupt clock access method."
Comment 4 Joe Orton 2002-01-17 08:20:48 EST
Additional info is that I never had any problems running hwclock (without
--directisa) using a 2.2 kernel on the same machine.
Comment 5 Joe Orton 2002-01-17 08:31:14 EST
(Oops, that flag needs to be added to /etc/sysconfig/clock for the workaround)
Comment 6 Elliot Lee 2002-01-29 17:20:11 EST
I'll suggest to the util-linux maintainer to incorporate the forked hwclock -
otherwise, I'm not going to touch hwclock for fear of blowing up on a lot of
other systems (e.g. architectures that don't know what an ISA bus is :).

The workaround is to boot with init=/bin/sh the first time and hack up
/etc/sysconfig/hwclock.
Comment 7 Elliot Lee 2002-03-27 10:40:10 EST
*** Bug 55683 has been marked as a duplicate of this bug. ***
Comment 8 Elliot Lee 2002-03-27 10:40:45 EST
*** Bug 62094 has been marked as a duplicate of this bug. ***
Comment 9 Joe Orton 2002-10-02 05:18:50 EDT
This appears to be fixed in 8.0.
Comment 10 Joe Orton 2002-10-14 14:00:10 EDT
Or maybe it's not fixed. I enabled automatic power-on (at a given time) in my
BIOS, and now hwclock hangs again (repeatably) without the --directisa flag.
I'll try disabling automatic power-on and see if I can boot without passing
--directisa to hwclock.

Note You need to log in before you can comment on or make changes to this bug.