Bug 557386 - changes in do_coredump breaks ABRT
Summary: changes in do_coredump breaks ABRT
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F13Alpha, F13AlphaBlocker 557387 560992 567331
TreeView+ depends on / blocked
 
Reported: 2010-01-21 09:55 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:50 UTC (History)
13 users (show)

Fixed In Version: kernel-2.6.33-0.47.rc8.git1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 557387 567331 (view as bug list)
Environment:
Last Closed: 2010-02-24 19:14:46 UTC


Attachments (Terms of Use)

Description Jiri Moskovcak 2010-01-21 09:55:05 UTC
Description of problem:
This patch changes the behavior when there is a pipe in /proc/sys/core_pattern and it breaks ABRT.
http://android.git.kernel.org/?p=kernel/linux-2.6.git;a=commitdiff;h=725eae32df7754044809973034429a47e6035158

Version-Release number of selected component (if applicable):
kernel 2.6.32

How reproducible:
100%

Steps to Reproduce:
1. install kernel 2.6.32
2. install abrt
3. crash something and instead of coredump you'll see this in dmesg:

Process 2739(gvfsd-trash) has RLIMIT_CORE set to 0
Aborting core

and abrt fails to detect it.

Comment 1 MartinG 2010-01-27 20:12:04 UTC
I see this too:
2.6.33-0.18.rc4.git7.fc13.x86_64

Process 2071(hal-disable-pol) has RLIMIT_CORE set to 0
Aborting core

If the patch is applied in koji,  I'd be happy to test it.

Comment 2 Neil Horman 2010-02-04 19:44:03 UTC
a patch for this got pulled into -mm, I'll backport to rawhide, and kick off a koji build shortly.

Comment 3 Neil Horman 2010-02-05 13:24:03 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=1964481

Could you verify this build works the way you expect please?

Comment 4 Jiri Moskovcak 2010-02-07 13:42:07 UTC
Hi,
just tried that kernel and ABRT detects crashes, but now the dump helper has troubles to readlink /proc/<pid>/exe, is it possible, that it disappears before the dump helper is done?

Jirka

Comment 5 Neil Horman 2010-02-07 19:12:02 UTC
i'm glad it works.  As for the dissappearing /proc/pid/exe files, you should read the git commit log more closely regarding the patch that started all this consternation.  One of the reported bugs that that set fixes is the race between the cleanup of the crashing process and the collection of the dump.  theres a new sysctl called core_pipe_limit that you need to set to guarantee the prevent that race condition.  It only worked previously by good fortune

Comment 6 Jiri Moskovcak 2010-02-07 19:25:14 UTC
Ok, I will take a deeper look into it on Monday, now I gave it just a few minutes to install the kernel and test if abrt-hook is called when crash happens.

Thanks,
Jirka

Comment 7 Neil Horman 2010-02-09 11:41:41 UTC
ok, let me know when you get to testing it

Comment 8 Jiri Moskovcak 2010-02-14 12:48:43 UTC
The second version seems to works fine, now I need to implement the core_pipe_limit setting in abrt.

Thanks,
J.

Comment 9 Neil Horman 2010-02-15 20:41:13 UTC
commited to rawhide.

Comment 10 Jesse Keating 2010-02-23 01:52:33 UTC
Has there been a kernel build since this was committed?

Comment 11 Adam Williamson 2010-02-23 20:46:08 UTC
kernel -51 fixed this, I believe. I have tested abrt 1.0.8 plus kernel -52; abrt works in that combination.


Note You need to log in before you can comment on or make changes to this bug.