Bug 567331 - changes in do_coredump breaks ABRT
Summary: changes in do_coredump breaks ABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 568049 (view as bug list)
Depends On: 557386
Blocks: F13Alpha, F13AlphaBlocker 557387 560992
TreeView+ depends on / blocked
 
Reported: 2010-02-22 16:56 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:51 UTC (History)
17 users (show)

Fixed In Version: abrt-1.0.8-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of: 557386
Environment:
Last Closed: 2010-02-26 02:22:22 UTC


Attachments (Terms of Use)

Description Jiri Moskovcak 2010-02-22 16:56:47 UTC
+++ This bug was initially created as a clone of Bug #557386 +++

Description of problem:
This patch changes the behavior when there is a pipe in /proc/sys/core_pattern and it breaks ABRT.
http://android.git.kernel.org/?p=kernel/linux-2.6.git;a=commitdiff;h=725eae32df7754044809973034429a47e6035158

Version-Release number of selected component (if applicable):
kernel 2.6.32

How reproducible:
100%

Steps to Reproduce:
1. install kernel 2.6.32
2. install abrt
3. crash something and instead of coredump you'll see this in dmesg:

Process 2739(gvfsd-trash) has RLIMIT_CORE set to 0
Aborting core

and abrt fails to detect it.

--- Additional comment from gronslet@gmail.com on 2010-01-27 15:12:04 EST ---

I see this too:
2.6.33-0.18.rc4.git7.fc13.x86_64

Process 2071(hal-disable-pol) has RLIMIT_CORE set to 0
Aborting core

If the patch is applied in koji,  I'd be happy to test it.

--- Additional comment from nhorman@redhat.com on 2010-02-04 14:44:03 EST ---

a patch for this got pulled into -mm, I'll backport to rawhide, and kick off a koji build shortly.

--- Additional comment from nhorman@redhat.com on 2010-02-05 08:24:03 EST ---

http://koji.fedoraproject.org/koji/taskinfo?taskID=1964481

Could you verify this build works the way you expect please?

--- Additional comment from jmoskovc@redhat.com on 2010-02-07 08:42:07 EST ---

Hi,
just tried that kernel and ABRT detects crashes, but now the dump helper has troubles to readlink /proc/<pid>/exe, is it possible, that it disappears before the dump helper is done?

Jirka

--- Additional comment from nhorman@redhat.com on 2010-02-07 14:12:02 EST ---

i'm glad it works.  As for the dissappearing /proc/pid/exe files, you should read the git commit log more closely regarding the patch that started all this consternation.  One of the reported bugs that that set fixes is the race between the cleanup of the crashing process and the collection of the dump.  theres a new sysctl called core_pipe_limit that you need to set to guarantee the prevent that race condition.  It only worked previously by good fortune

--- Additional comment from jmoskovc@redhat.com on 2010-02-07 14:25:14 EST ---

Ok, I will take a deeper look into it on Monday, now I gave it just a few minutes to install the kernel and test if abrt-hook is called when crash happens.

Thanks,
Jirka

--- Additional comment from nhorman@redhat.com on 2010-02-09 06:41:41 EST ---

ok, let me know when you get to testing it

--- Additional comment from jmoskovc@redhat.com on 2010-02-14 07:48:43 EST ---

The second version seems to works fine, now I need to implement the core_pipe_limit setting in abrt.

Thanks,
J.

--- Additional comment from nhorman@redhat.com on 2010-02-15 15:41:13 EST ---

commited to rawhide.

Comment 1 Jiri Moskovcak 2010-02-22 16:58:59 UTC
There had to be some changes on ABRT's side, so I'm opening this bugzilla to track it. The fix has been committed and tested.

J.

Comment 2 Fedora Update System 2010-02-22 17:07:34 UTC
abrt-1.0.8-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/abrt-1.0.8-1.fc13

Comment 3 Fedora Update System 2010-02-23 16:09:54 UTC
abrt-1.0.8-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update abrt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2697

Comment 4 Adam Williamson 2010-02-23 19:22:34 UTC
just to note I've tested the combination of abrt-1.0.8-1.fc13 and kernel 2.6.33-0.52.rc8.git6.fc13.x86_64, and this produces a working abrt.

Comment 5 Jiri Moskovcak 2010-02-25 09:50:09 UTC
*** Bug 568049 has been marked as a duplicate of this bug. ***

Comment 6 Tom London 2010-02-25 14:23:25 UTC
Sorry, this is not "fixed for me" with (Rawhide):

abrt-1.0.8-1.fc14.x86_64
and
kernel-2.6.33-0.48.rc8.git1.fc14.x86_64

Here is what happens when firefox segfaults:

Feb 25 06:20:07 tlondon abrt[2803]: saved core dump of pid 2473 (/usr/lib64/firefox-3.6/firefox) to /var/cache/abrt/ccpp-1267107607-2473.new/coredump (0 bytes)
Feb 25 06:20:07 tlondon abrtd: Directory 'ccpp-1267107607-2473' creation detected
Feb 25 06:20:07 tlondon abrt[2803]: saved core dump of pid 2473 to /home/tbl/core.2473 (0 bytes)
Feb 25 06:20:07 tlondon abrtd: New crash /var/cache/abrt/ccpp-1267107607-2473, processing
Feb 25 06:20:07 tlondon abrtd: Registered Action plugin 'RunApp'
Feb 25 06:20:07 tlondon abrtd: RunApp('/var/cache/abrt/ccpp-1267107607-2473','test x"`cat component`" = x"xorg-x11-server-Xorg" && cp /var/log/Xorg.0.log .')

Here is the resulting 0 length core file:

[tbl@tlondon ~]$ ls -l core.2473
-rw-------. 1 tbl tbl 0 Feb 25 06:20 core.2473
[tbl@tlondon ~]$

Comment 7 Jiri Moskovcak 2010-02-25 15:39:00 UTC
(In reply to comment #6)
> Sorry, this is not "fixed for me" with (Rawhide):
> 
> abrt-1.0.8-1.fc14.x86_64
> and
> kernel-2.6.33-0.48.rc8.git1.fc14.x86_64
> 

Please, see the comment #4 this bug required fixes on both ABRT and kernel side, so only the right combination will work:
 abrt >= 1.0.8 AND kernel >= 2.6.33-0.52.rc8.git6.fc13

Comment 8 Adam Williamson 2010-02-26 02:22:22 UTC
besides, your test actually proves that abrt itself is working fine and you only suffered from the kernel-breaking-coredumps issue. so we can close this.

(abrt has been behaving fine for me all day, too.)

Comment 9 Fedora Update System 2010-02-26 11:51:43 UTC
abrt-1.0.8-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.