Bug 55741 - runlevel 1 and sulogin produces weird results
runlevel 1 and sulogin produces weird results
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-05 17:04 EST by Mike
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 09:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2001-11-05 17:04:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

Description of problem:
After upgrading to util-linux-2.11f-12.i386 and going to runlevel 1,
commands that are issued are not interpreted by bash properly. When
entering level 1 error "sh: no job control in this shell" is displayed .
Also if there is line in inittab to run sulogin when entering runlevel 1,
login never really happens.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to util-linux-2.11f-12.i386 from version 2.11f-9
2. Reboot and after logging in, go init 1
3.
	

Actual Results:  

init 1

<usual service shutdown messages>

sh: no job control in this shell
sh-2.05# w
<actual w output>
[root@ns1 root]# free
bash: ree: command not found
[root@ns1 root]# free
bash: ree: command not found
[root@ns1 root]# <hit enter>
sh: ff: command not found
sh-2.05# free
<actual output of free>


Expected Results:  The shell should read the commands properly.

Additional info:

Similarly, if I have a line ~~:S:wait:/sbin/sulogin in inittab file and I
change to runlevel 1 I get the maintenance prompt asking for root password.
After I punch in the root password, the password is echoed to the console

bash: <password>: command not found
[root@ns1 root]#

then I can issue a few commands before I get asked for the root password
again. Then the same thing happens, password is echoed to the console. if I
type init 3 from there, I get taken back to level 3. When logging in, after
typing root for username, '^M' is appended to the end of username and
password prompt is displayed on the same line adter username prompt. Login
happens as expected, however
Comment 1 Michael Schwendt 2001-11-06 09:08:11 EST
Crosslinking similar (maybe duplicate) bug reports again: bug #55181
Comment 2 Elliot Lee 2001-11-21 11:03:29 EST

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.