Bug 55181 - errata kernel virtual tty problems under 7.2
Summary: errata kernel virtual tty problems under 7.2
Status: CLOSED DUPLICATE of bug 54741
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-26 18:22 UTC by echristo
Modified: 2007-04-18 16:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 15:52:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description echristo 2001-10-26 18:22:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011014

Description of problem:
One thing I noticed during boot up was:
getgrnam failed for getgrnam failed for %s

Just before it enabled the swap space.

When you log into a virtual tty the error message:

Warning: no access to tty (Inappropriate ioctl for device).
Thus no job control in this shell.

When you log in as root you get the addition of:
/proc/866/fd/15: No such file or directory.

More symptoms:

nfs device unmounts don't work quite right and often give rpc
errors. These drives are netapps mounted either with nfsver=2 or 3, and
either udp or tcp.

For UP kernels I will occasionally have to log in a few times to duplicate
this, however, it does happen eventually.  SMP kernels are much easier to
make this happen.

I can log in via ssh perfectly well and seem to have all of the job
control I want that way.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. See above
2.
3.
	

Additional info:

Comment 1 Greg Bailey 2001-10-26 23:17:58 UTC
I've run into an annoying problem periodically, and I'm wondering if this is the
same one...  when this happens to you:

1.  Does CTRL-C work?  Mine doesn't.
2.  When I do a "su -", I get "bash: no job control in this shell"

I can happen both in text mode and in X-Windows.  If I log out on the console,
and then log in again, the problem usually goes away.

Comment 2 Scott Wilburn 2001-10-27 02:19:43 UTC
I see this problem with console logins as well and it does seem to only occur
after applying the updates. Could this be in the util-linux update? Haven't seen
it on all my machines, in particular the two laptops have yet to show it.
Probably coincidental. I do hack /etc/pam.d/system-auth, but only the auth section.

Comment 3 Michael Schwendt 2001-10-27 12:16:20 UTC
Just to crosslink all these symptoms, many people have experienced the same or
similar bugs with the Seawolf updates (util-linux-2.11f-11.7.1), e.g. bug #54865
and bug #54741. So far, I haven't got anything like that with Enigma and thought
it was specific to Seawolf. Interesting, that it is not.



Comment 4 Need Real Name 2001-10-28 17:56:17 UTC
This isn't just a vty problem. I'm also seeing this on serial console with
Redhat 7.2.  It is especially annoying because ssh complains: "You have no
controlling tty.  Cannot read passphrase."

The output of strace reveals this error: 
open("/dev/tty", O_RDONLY|O_LARGEFILE)  = -1 ENXIO (No such device or address)

cat /dev/tty complains likewise.

Comment 5 Michael Schwendt 2001-11-06 14:13:26 UTC
Another one: bug #55741

Comment 6 Elliot Lee 2001-11-21 16:05:00 UTC

*** This bug has been marked as a duplicate of 54741 ***


Note You need to log in before you can comment on or make changes to this bug.