Bug 557451 - mesa-7.8-0.11.fc13 causes text/screen corruption (with compiz enbled)
Summary: mesa-7.8-0.11.fc13 causes text/screen corruption (with compiz enbled)
Keywords:
Status: CLOSED DUPLICATE of bug 618679
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-21 14:41 UTC by Tom London
Modified: 2010-09-14 13:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 13:18:10 UTC


Attachments (Terms of Use)
Screenshot showing mangled text (125.32 KB, image/jpeg)
2010-02-08 17:06 UTC, Tom London
no flags Details
Screenshot showing gnome-terminal window with garbled characters... (10.73 KB, image/png)
2010-03-12 19:33 UTC, Tom London
no flags Details

Description Tom London 2010-01-21 14:41:43 UTC
Description of problem:
After updating to koji mesa package:
mesa-dri-drivers-7.8-0.11.fc13.x86_64
mesa-libGL-7.8-0.11.fc13.x86_64
mesa-libGLU-7.8-0.11.fc13.x86_64
mesa-libGL-devel-7.8-0.11.fc13.x86_64
mesa-libGLU-devel-7.8-0.11.fc13.x86_64

my compiz enabled desktop starts suffering from "text corruption/delay": when I type in a console window, some characters are displayed as solid black character-sized rectangles, and I randomly see a "newline delay" (that is, I sometimes have to enter 2 newlines to see effect in the window).

This problem "goes away" if I disable compiz or if I downgrade to 
mesa-dri-drivers-7.8-0.10.fc13.x86_64
mesa-libGL-7.8-0.10.fc13.x86_64
mesa-libGLU-7.8-0.10.fc13.x86_64
mesa-libGL-devel-7.8-0.10.fc13.x86_64
mesa-libGLU-devel-7.8-0.10.fc13.x86_64

Version-Release number of selected component (if applicable):
mesa-dri-drivers-7.8-0.11.fc13.x86_64
mesa-libGL-7.8-0.11.fc13.x86_64
mesa-libGLU-7.8-0.11.fc13.x86_64
mesa-libGL-devel-7.8-0.11.fc13.x86_64
mesa-libGLU-devel-7.8-0.11.fc13.x86_64

How reproducible:
yes, every time

Steps to Reproduce:
1. upgrade to newer mesa packages
2. enable compiz
3. start entering text in console windows, etc.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2010-01-27 14:48:14 UTC
Problem continues with mesa-*-7.8-0.12.fc13.x86_64.rpm

Updating while I have compiz enabled caused console windows to misbehave: some character are displayed as black rectangles, some newlines are not displayed, command output is not displayed until I hit another newline, etc.

Comment 2 Tom London 2010-01-27 14:51:25 UTC
Not sure its relevant, but I have Intel graphics:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)

Running

xorg-x11-drv-intel-2.10.0-2.fc13.x86_64
xorg-x11-server-common-1.7.99.3-1.20100120.fc13.x86_64
xorg-x11-server-utils-7.4-15.fc13.x86_64
xorg-x11-server-Xorg-1.7.99.3-1.20100120.fc13.x86_64

Comment 3 Tom London 2010-02-03 16:51:15 UTC
Corrupt behavior continues with mesa*-7.8-0.13.fc13.x86_64.rpm

Workaround: revert to mesa*-7.8-0.10.fc13.x86_64.rpm

Comment 4 Tom London 2010-02-04 14:46:52 UTC
Corrupt behavior continues with mesa*-7.8-0.14.fc13.x86_64.rpm

Workaround: revert to mesa*-7.8-0.10.fc13.x86_64.rpm

Comment 5 Tom London 2010-02-08 17:06:15 UTC
Created attachment 389579 [details]
Screenshot showing mangled text

Continued mangling of text, etc. with mesa-*-7.8-0.16.fc13.x86_64.rpm

Reverting to mesa-*-7.8-0.10.fc13.x86_64.rpm continues to "fix".

I attach a phone-cam shot of screen showing two terminal windows with black rectangles for text.

I entered "date" in both windows......

Comment 6 Tom London 2010-02-12 17:07:45 UTC
This continues for me with current rawhide/koji.

-16 doesn't work with compiz enabled; -10 does.

Continue to get intermittent "black rectangles" instead of characters, delayed output to terminal commands (e.g., I have to hit "Enter" twice to get output of command displayed), miss-drawn tabs in gnome-terminal, terminal display "all black" instead of white background, etc.

Suggestions on how I can debug and/or provide useful information?

Comment 7 Tom London 2010-02-18 14:37:47 UTC
This issue continues with current rawhide/koji:

xorg-x11-server-Xorg-1.7.99.901-4.20100215.fc14.x86_64
compiz-0.8.4-5.fc13.x86_64
libdrm-2.4.18-0.1.fc13.x86_64
xorg-x11-drv-intel-2.10.0-4.fc13.x86_64
and mesa*-16*

Anything I can do/more I can provide to help?

Comment 8 Tom London 2010-02-24 16:48:54 UTC
mesa-7.8-0.18.fc13 continues to be broken for me: Intel graphics/compiz.

I have to revert to mesa-7.8-0.10.fc13 to get it to "work for me".

Comment 9 Tom London 2010-03-03 17:16:04 UTC
I continue to have "text/window corruption" each and every time I update mesa past -0.10 when I run compiz on my Intel-based laptop (now with -0.18) running Rawhide.

Typically, the corruption begins after I login/reboot after updating.

The corruption goes away when I revert to -0.10 and logout/login (or disable compiz/re-enable compiz).

Anything I can provide to help?  Xorg.0.log?  ~/.xsession-errors?

Comment 10 Ola Thoresen 2010-03-10 21:16:23 UTC
Same issue here.
Intel graphics here as well.

Other symptoms:
Arrow back and forward in a text-window will leave a "ghost"-cursor hanging in the last position the cursor was in.

Sometimes scrolling large pages (I.E in firefox or thunderbird) will add "layers of text" on top of each other at the bottom of the window.

Most "fancy" javascript/css-functionality (changing background-color, displaying hidden layers and so on) on webpages often will not show up.

Usually switching to another desktop and back again ill make all artifacts go away.

xorg-x11-drv-intel-2.10.0-4.fc13.i686

mesa-libGL-devel-7.8-0.18.fc13.i686
mesa-dri-drivers-7.8-0.18.fc13.i686
mesa-debuginfo-7.6-0.8.fc12.i686
mesa-libGLU-7.8-0.18.fc13.i686
mesa-libGLU-devel-7.8-0.18.fc13.i686
mesa-libGL-7.8-0.18.fc13.i686

Comment 11 Tom London 2010-03-12 19:33:42 UTC
Created attachment 399725 [details]
Screenshot showing gnome-terminal window with garbled characters...

This is continuing to happen to me each time I update from mesa-*-7.8-0.10.fc13.x86_64.

Is this a known issue?

Would it be helpful for me to provide some other information?

Would it be helpful for me to attempt to bisect this?  [I believe the problem was introduced with 0.11.fc13.x86_64]

Again, I'm running Thinkpad X200.  Here is output of 'lspci':

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

Besides mesa, here are other package versions:

compiz-fusion-extras-gnome-0.8.4-1.fc13.x86_64
compiz-fusion-unsupported-0.8.4-1.fc13.x86_64
xorg-x11-server-common-1.7.99.901-10.20100304.fc14.x86_64
compiz-fusion-unsupported-devel-0.8.4-1.fc13.x86_64
compiz-fusion-gnome-0.8.4-2.fc13.x86_64
compiz-0.8.4-6.fc14.x86_64
xorg-x11-server-Xorg-1.7.99.901-10.20100304.fc14.x86_64
compizconfig-python-0.8.4-1.fc13.x86_64
compiz-fusion-unsupported-gnome-0.8.4-1.fc13.x86_64
xorg-x11-drivers-7.3-14.fc14.x86_64
libdrm-devel-2.4.18-1.fc14.x86_64
xorg-x11-server-utils-7.4-16.fc14.x86_64
compiz-fusion-0.8.4-2.fc13.x86_64
ptouch-driver-1.3-2.fc12.x86_64
compiz-fusion-devel-0.8.4-2.fc13.x86_64
xorg-x11-drv-intel-2.10.0-4.fc13.x86_64
compiz-fusion-extras-devel-0.8.4-1.fc13.x86_64
libdrm-debuginfo-2.4.18-1.fc14.x86_64
compiz-gnome-0.8.4-6.fc14.x86_64
compiz-fusion-extras-0.8.4-1.fc13.x86_64
compiz-debuginfo-0.8.4-6.fc14.x86_64
libdrm-2.4.18-1.fc14.x86_64
compiz-devel-0.8.4-6.fc14.x86_64

Comment 12 Tom London 2010-03-12 19:37:48 UTC
Slightly more detail: After I update mesa packages, all is OK until I reboot or logoff/login.

Comment 13 Bug Zapper 2010-03-15 14:10:07 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 14 Tom London 2010-03-30 15:53:27 UTC
I continue to have this problem with rawhide, so I'm changing this back to rawhide.

I updated to:
Mar 29 09:32:25 Updated: mesa-dri-drivers-7.8-0.18.fc13.x86_64
Mar 29 09:32:26 Updated: mesa-libGL-7.8-0.18.fc13.x86_64
Mar 29 09:32:27 Updated: mesa-libGLU-7.8-0.18.fc13.x86_64
Mar 29 09:32:29 Updated: mesa-libGL-devel-7.8-0.18.fc13.x86_64
Mar 29 09:32:30 Updated: mesa-libGLU-devel-7.8-0.18.fc13.x86_64

and got corrupted screen.

As per comment #11, most of other packages are fc14.

Any other information I can provide?

Comment 15 Tom London 2010-03-30 17:52:44 UTC
Just updated a bunch of compiz packages from koji, but no change: with mesa-7.8.0.18.fc13.x86_64, I get messed up display of text, etc.

Here is the list of currently installed compiz type packages:

[root@tlondon ~]# rpm -qa \*compiz\*
compiz-fusion-devel-0.8.6-1.fc14.x86_64
compiz-fusion-gnome-0.8.6-1.fc14.x86_64
compiz-fusion-unsupported-0.8.4-1.fc13.x86_64
compiz-fusion-unsupported-devel-0.8.4-1.fc13.x86_64
compiz-fusion-0.8.6-1.fc14.x86_64
compiz-devel-0.8.6-1.fc14.x86_64
compizconfig-python-0.8.4-1.fc13.x86_64
compiz-fusion-unsupported-gnome-0.8.4-1.fc13.x86_64
compiz-fusion-extras-0.8.6-1.fc14.x86_64
compiz-fusion-extras-gnome-0.8.6-1.fc14.x86_64
libcompizconfig-debuginfo-0.8.4-1.fc13.x86_64
compiz-0.8.6-1.fc14.x86_64
compiz-gnome-0.8.6-1.fc14.x86_64
libcompizconfig-0.8.4-2.fc14.x86_64
compiz-debuginfo-0.8.4-6.fc14.x86_64
compiz-fusion-extras-devel-0.8.6-1.fc14.x86_64
[root@tlondon ~]# 

They all appear to be fc14 except compiz-fusion-unsupported and compizconfig-python......

Comment 16 Jonathan Dieter 2010-04-03 09:05:15 UTC
This bug is still in Fedora 13 up-to-date as of today.

# lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
(snip)

Comment 17 Tom London 2010-04-03 16:38:59 UTC
I notice a "newer" mesa working its way through koji: mesa-7.8-1.fc13.

Perhaps that will "fix" this?

Otherwise, I'm still running with mesa-*-7.8-0.10.fc13.x86_64.

Comment 18 Tom London 2010-04-12 13:19:45 UTC
Still fails with 

mesa-libGLU-7.8.1-1.fc13.x86_64
mesa-libGL-devel-7.8.1-1.fc13.x86_64
mesa-dri-drivers-7.8.1-1.fc13.x86_64
mesa-libGL-7.8.1-1.fc13.x86_64
mesa-libGLU-devel-7.8.1-1.fc13.x86_64
and
compiz-0.8.6-1.fc14.x86_64

Still get "corrupted text" and "missing new lines" and ... as above when I have compiz enabled.  Works fine with metacity.

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

As above, compiz works fine with mesa-*-7.8-0.10.fc13.x86_64.

Comment 19 Volker Braun 2010-04-14 02:02:30 UTC
I see the same with i5-520m (Arrandale) integrated graphics (Thinkpad T410s):

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 06)

So it seems like various Intel integrated graphics are affected, but not other manufacturers. Also, note that the switch which broke things was:

* Thu Jan 21 2010 Dave Airlie <airlied@redhat.com> 7.8-0.11
- rebase for new DRI2 API

It is possible that the bug is within Intel's DRI2 support and was just uncovered by the mesa change.

It would be interesting to see if this persists in the recent Intel 2010Q1 release.

Comment 20 Adrie Taniwidjaja 2010-04-19 14:44:44 UTC
I have the same problem too with Intel D945GCLF2 :

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

and

Installed Packages
mesa-dri-drivers.i686    7.8.1-1.fc13
mesa-libGL.i686          7.8.1-1.fc13
mesa-libGLU.i686         7.8.1-1.fc13

before upgrading to 7.8.1 I saw this problem too with 7.8.0 version.

But if I disable compiz it was ok ....

Comment 21 Tom London 2010-04-23 22:02:31 UTC
Updating to mesa-7.8.1-2.fc13.x86_64 packages "makes this work for me".

Comment 22 Adrie Taniwidjaja 2010-04-24 02:52:52 UTC
Updating to mesa-7.8.1-2.fc13.i686 works partly. It solved the problem when I don't have any duplicate active windows in the screen. 

As an example I run a terminal on the screen. It's ok, I call Firefox still ok. But when I run the terminal again (a second terminal) the display of the new terminal duplicate the first terminal. I run Firefox again the display screen of the second Firefox duplicate the first one.

Comment 23 Bug Zapper 2010-07-30 10:49:50 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 24 Tom London 2010-09-14 13:18:10 UTC

*** This bug has been marked as a duplicate of bug 618679 ***


Note You need to log in before you can comment on or make changes to this bug.