Bug 618679 - massive redrawing problems with intel 2.12
massive redrawing problems with intel 2.12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
: 557451 611588 613118 (view as bug list)
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-07-27 10:27 EDT by Felix Möller
Modified: 2011-03-02 04:21 EST (History)
7 users (show)

See Also:
Fixed In Version: xorg-x11-drv-intel-2.12.0-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 01:07:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/Xorg.0.log (84.45 KB, text/plain)
2010-07-27 18:38 EDT, Felix Möller
no flags Details
dmesg (113.04 KB, text/plain)
2010-07-27 18:38 EDT, Felix Möller
no flags Details
/var/log/messages (782.30 KB, text/plain)
2010-07-27 18:40 EDT, Felix Möller
no flags Details

  None (edit)
Description Felix Möller 2010-07-27 10:27:21 EDT
I have been running F13 with the new intel 2.12 driver from koji until yesterday. It worked perfectly.

Today I updated to F14 (rawhide), but there is some major redrawing problem. I cannot take a screenshot of it, as it seems like ksnapshot corrects the problem.

It can be especially seen when moving the mouse quickly within a context menu. This causes several entries to be hightlighted in blue ... The message header in Thunderbird has huge problems too...

Typing this text in chrome, makes some letter just appear after a second has been typed. But this seems to be nondeterministic ... :-(

Any idea what to try appreciated ...

Before I was using: <http://koji.fedoraproject.org/koji/buildinfo?buildID=179735>
Now I have: 
xorg-x11-drv-intel-2.12.0-4.fc14.i686
Comment 1 Felix Möller 2010-07-27 10:38:43 EDT
Disabling compiz seems to "solve" this bug.
Comment 2 Matěj Cepl 2010-07-27 17:43:12 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

Also, could you just take a photograph of the screen when the corruption happens?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Felix Möller 2010-07-27 18:38:14 EDT
Created attachment 434874 [details]
/var/log/Xorg.0.log
Comment 4 Felix Möller 2010-07-27 18:38:54 EDT
Created attachment 434875 [details]
dmesg
Comment 5 Felix Möller 2010-07-27 18:40:32 EDT
Created attachment 434876 [details]
/var/log/messages
Comment 6 Bug Zapper 2010-07-30 08:53:19 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Felix Möller 2010-07-31 04:40:23 EDT
I recognized something interesting. The problems do not occur when running gnome-shell...
Comment 8 Andreas Bierfert 2010-08-11 00:06:27 EDT
Same problem on x86_64.
Comment 9 Felix Möller 2010-08-24 13:28:11 EDT
This problem still persists:
fm@thinkpad:~ # rpm -q xorg-x11-drv-intel 
xorg-x11-drv-intel-2.12.0-4.fc14.i686
fm@thinkpad:~ # uname -a
Linux thinkpad 2.6.35.2-9.fc14.i686.PAE #1 SMP Tue Aug 17 22:36:11 UTC 2010 i686 i686 i386 GNU/Linux
Comment 10 Andreas Bierfert 2010-08-25 09:49:53 EDT
Same here with compiz:

rpm -q xorg-x11-drv-intel compiz mesa-libGL

xorg-x11-drv-intel-2.12.0-4.fc14.x86_64
compiz-0.8.6-3.fc14.x86_64
mesa-libGL-7.9-0.6.fc14.x86_64
mesa-libGL-7.9-0.6.fc14.i686

uname -rv

2.6.35.2-9.fc14.x86_64 #1 SMP Tue Aug 17 22:36:15 UTC 2010
Comment 11 Andreas Bierfert 2010-08-25 10:22:52 EDT
I just did a build with a fresh git snapshot and after a little testing everything seems to work. I currently don't have time to do some digging but maybe someone more involved upstream could do some bisecting or push a fresh build...
Comment 12 Felix Möller 2010-08-27 15:36:56 EDT
I have compiled todays git master and created a rpm from it. This solves the problem for me too.

Thanks Andreas for testing!
Comment 13 Felix Möller 2010-08-27 16:33:53 EDT
The fix is between 42312bbd8c9cbadf0adc4556b76987857d105bd9 (2010-08-22 08:54:18) and 938ef4eaec0e406e198105d866f6d2a1be5e0ef8 ( 2010-07-28 11:57:42).

Sadly the backlight does not shine with current git anymore... :-(
Comment 14 Felix Möller 2010-08-29 18:22:08 EDT
I was not able to bisect the issue. As I got crashes in several revisions and furthermore. The content of my screen got offseted by arround 80px. I.e. The total left appeared on the right side while mouse clicks still went to the normal position. This was somehow not depending on the revision but on hardware state -- all known good revisions showed this problem at some time. After several reboots I was afraid of broken hardware. It was fixed by leaving the notebook off for several hours.

But I was successfully in getting current git master running successfully on my hardware for which I needed to bisect too. Have a look at <https://bugs.freedesktop.org/show_bug.cgi?id=29845> where I documented which patch to remove. As otherwise my backlight was not working at all.
Comment 15 Steven Haigh 2010-09-09 13:15:02 EDT
I have a similar problem with an intel video card & compiz on F14...

$ rpm -q xorg-x11-drv-intel compiz mesa-libGL
xorg-x11-drv-intel-2.12.0-4.fc14.i686
compiz-0.8.6-3.fc14.i686
mesa-libGL-7.9-0.6.fc14.i686
$ uname -rv
2.6.35.4-12.fc14.i686.PAE #1 SMP Fri Aug 27 07:47:26 UTC 2010

xorg-x11-drv-intel-2.12.0-4.fc14.i686

00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller

from Xorg.0.log:
[    48.278] (II) intel(0): Integrated Graphics Chipset: Intel(R) Pineview GM
[    48.278] (--) intel(0): Chipset: "Pineview GM"
[    48.278] (==) intel(0): video overlay key set to 0x101fe

It seems this issue goes away when turning off compiz.
Comment 16 Steven Haigh 2010-09-12 13:48:40 EDT
This could well be related to this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=613118
Comment 17 Adel Gadllah 2010-09-13 15:06:53 EDT
*** Bug 613118 has been marked as a duplicate of this bug. ***
Comment 18 Adel Gadllah 2010-09-13 15:07:46 EDT
Please test this scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2465275 it contains an upstream backport that is supposed to fix the issue.
Comment 19 Felix Möller 2010-09-13 16:07:06 EDT
the koji build works for me. thanks.
Comment 20 Fedora Update System 2010-09-13 16:43:57 EDT
xorg-x11-drv-intel-2.12.0-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.12.0-6.fc14
Comment 21 Steven Haigh 2010-09-13 22:11:51 EDT
Seems to fix the issue for me as well.
Comment 22 Fedora Update System 2010-09-14 01:07:35 EDT
xorg-x11-drv-intel-2.12.0-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Tom London 2010-09-14 09:18:10 EDT
*** Bug 557451 has been marked as a duplicate of this bug. ***
Comment 24 Tom London 2010-09-14 10:26:02 EDT
*** Bug 611588 has been marked as a duplicate of this bug. ***
Comment 25 warluswarlus 2011-03-02 04:21:34 EST
it seems to me this bug is still alive in my system,
f13 , some text in some resolutions becomes black rectangles.
if I resize the window , text pop back if cursor is moved above text.
problem is solved if I switch screen resolutions.

picture of the rectangles : 

http://img46.imageshack.us/i/rectangles2.jpg/

I have NVIDIA Driver Version:173.14.28


uname -r
2.6.34.7-66.fc13.i686

any suggestions ?

Note You need to log in before you can comment on or make changes to this bug.