Bug 55764 - modutils 2.4.6-4 won't unload modules (missing kmod cron job)
Summary: modutils 2.4.6-4 won't unload modules (missing kmod cron job)
Status: CLOSED DUPLICATE of bug 16608
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: modutils   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-06 12:10 UTC by ckulesa
Modified: 2014-03-17 02:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 12:12:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ckulesa 2001-11-06 12:10:48 UTC
Description of Problem:

Redhat 7.2 does not include /etc/cron.d/kmod in the modutils package, which means that unused (autoclean) kernel modules will not be removed from memory! 



Version-Release number of component:

modutils 2.4.6-4 as shipped with Redhat 7.2



How Reproducible:

Default upgrade from 7.1



Actual Results:

Unused modules never unload!



Expected Results:

Unused kernel modules should unload after 2 passes of the cron task every 10 minutes. 



Additional Information:



Solution! Rebuild modutils package, adding this to the SPEC file:

[it's all in one line but got word-wrapped in Web form]



echo "*/10 * * * *  root /sbin/rmmod -as"  >$RPM_BUILD_ROOT/etc/cron.d/kmod



And add /etc/cron.d/kmod to the list of files.

Comment 1 Bill Nottingham 2001-11-06 16:00:49 UTC
It was removed intentionally, due to user requests.

*** This bug has been marked as a duplicate of 16608 ***


Note You need to log in before you can comment on or make changes to this bug.