Bug 55776 - ppp-2.4.1-2 - Dial In PAM support broken for upgrade from 7.0
ppp-2.4.1-2 - Dial In PAM support broken for upgrade from 7.0
Status: CLOSED DUPLICATE of bug 55367
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-06 10:26 EST by Dennis DeDonatis
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-27 12:46:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diagnostic log, from Linux and Windows (3.41 KB, text/plain)
2001-11-27 12:46 EST, Kevin Cole
no flags Details

  None (edit)
Description Dennis DeDonatis 2001-11-06 10:26:06 EST
Description of Problem:

I upgraded from RedHat 7.0 and dial in to PPPd would stop with an IPCP 
timeout.  I installed the source RPM and ran ./configure, then cd pppd, 
then make and then cp -a pppd /usr/sbin.  It all works fine, now.  The 
default Makefile.linux has PAM=n.

Version-Release number of selected component (if applicable):

ppp-2.4.1-2 / ppp-2.4.1-2.src.rpm

How Reproducible:

Other people on have posted usenet news about the problem, but no one has 
posted a solution anywhere.

Steps to Reproduce:
1. Have pppd working in RH 7.0 (or possibly 6.2) and upgrade to 7.2 (or 
possibly (7.1).

Actual Results:

IPCP: timeout sending Config-Requests

Expected Results:

A valid logon.
Comment 1 Kevin Cole 2001-11-27 12:40:07 EST
The problem is not with PAM.  It is with the one of the CBCP patches added to
the source tarball.  When dialing in from another Linux box all is well.  When
dialing in from a Windows computer, it attempts to negotiate come callback
protocol stuff and fails.  Removing the two patches from the src RPM and
rebuilding it appeared to cure the problem for me.
Comment 2 Kevin Cole 2001-11-27 12:46:16 EST
Created attachment 38784 [details]
Diagnostic log, from Linux and Windows
Comment 3 Frank Ch. Eigler 2001-12-06 13:44:32 EST

*** This bug has been marked as a duplicate of 55367 ***

Note You need to log in before you can comment on or make changes to this bug.