Bug 55802 - Changing ip addresses and restarting the network won't assume the new values.
Summary: Changing ip addresses and restarting the network won't assume the new values.
Status: CLOSED DUPLICATE of bug 53531
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-06 21:49 UTC by Need Real Name
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 21:49:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-11-06 21:49:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
ip address network configuration is handled through
/etc/sysconfig/network-scripts/ifcfg-eth{something}. You set those
addresses initially with the anaconda network configuration utility. When I
tried to change this, I reedited the ifcfg-eth0 with the new ip address,
netmask, and so on. Then I restarted the network by issuing
/etc/init.d/network restart. The network "restarted" but the ip address
kept being the same even I verified the script before and after. The same
happens when I stopped the network, and started it again. However when we
stopped the network and removing the module from the kernel manually and
then starting it again, it worked.(The ip address got changed)

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.vi /etc/sysconfig/network-scripts/ifcfg-eth0
2./etc/init.d/network restart
3.
	

Actual Results:  It didn't change the ip address

Expected Results:  It should have changed the ip address of the NIC card

Additional info:


cat ifcfg-eth0 (after editing the file)

DEVICE=eth0
BOOTPROTO=static
#IPADDR=172.16.255.11
IPADDR=167.252.62.225
#BROADCAST=172.16.255.255
NETMASK=255.255.255.0
#NETWORK=172.16.255.0
ONBOOT=yes

[root@hobbes root]# /etc/init.d/network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down interface eth1:                              [  OK  ]
Disabling IPv4 packet forwarding:                          [  OK  ]
Setting network parameters:                                [  OK  ]
Bringing up interface lo:                                  [  OK  ]
Bringing up interface eth0:                                [  OK  ]
Bringing up interface eth1:                                [  OK  ]
[root@hobbes root]# ifconfig

eth0      Link encap:Ethernet  HWaddr 08:00:46:05:8A:FB  
          inet addr:172.16.255.11  Bcast:172.16.255.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:12 carrier:0
          collisions:0 
          RX bytes:0 (0.0 b)  TX bytes:504 (504.0 b)

Comment 1 Bill Nottingham 2001-11-06 21:57:29 UTC

*** This bug has been marked as a duplicate of 53531 ***

Comment 2 daniel 2002-01-23 19:24:32 UTC
Why is this closed ?  I have a dozen servers running 7.2 with this exact problem, the network scripts delete only the new address when bringing down 
the interface, and leaving the original.


Comment 3 Bill Nottingham 2002-01-23 19:44:00 UTC
It is closed as a duplicate of 53531, because it *is* a duplicate of 53531.
(And, a fix does exist.)

Comment 4 Need Real Name 2002-01-23 20:56:43 UTC
The actual solution was to upgrade to the newest version available according to
a message I got later that same day. What left me annoyed was that the _latest_
version was not on the 7.2 production RPMS tree, _but_ within the Rawhide.

Isn't Red Hat considering to release a stable version of the initscripts RPM in
the updates directory as an official update?

Thanks.
Carlos.

P.s. I'm using initscripts 6.40.2, right now...


Note You need to log in before you can comment on or make changes to this bug.