Bug 53531 - Network setup very unflexible
Network setup very unflexible
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 55802 55843 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-10 19:28 EDT by Chris Chabot
Modified: 2014-03-16 22:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 20:11:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Chabot 2001-09-10 19:28:33 EDT
When changing the IP address of a interface, it doesnt always apply when 
doing a ifdown / ifup. even network restart doesnt do the job.

I had this happen to me several times while playing with some new servers 
and RH Roswell beta 2 (+all updates). One eth was configured for the 
external net, one for internal (192...). When changing the 2 
configurations around, doing a ifup/down combo, didnt change the network 
settings of both, instead they both gor the internal address.

Interstingly enough, this seems to occur when the network card is also 
bound to the default gw (router) address. network restart didnt fix this 
situation either.

When doing a 'route' or ip route show, i saw that interface was still 
bound to the local network.

My suspission is that the new routing setup (iproute2) is not un-binding 
the interface from the routing table, thus is not allowing it to be re-
bound to a different network.

This greatly deacreases the flexibility of linux networking (no longer 
can we laugh @ win95 users who need to restart after a network change?!)
Comment 1 Chris Chabot 2001-09-10 20:11:48 EDT
Ps, after playing some more, i noticed chaning the IP within the same network 
range also did not work. When i tried this, the network cable was unplugged.

However the logs didnt show any errors, nor was there any visual output.

Could it be that when arpping fails, it doesnt change the ip?
Comment 2 Bill Nottingham 2001-09-26 16:43:48 EDT
This should be fixed at least somewhat in initscripts-6.40.1-1, or later.
Comment 3 Bill Nottingham 2001-11-06 16:57:22 EST
*** Bug 55802 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2001-11-07 12:34:03 EST
*** Bug 55843 has been marked as a duplicate of this bug. ***
Comment 5 Need Real Name 2001-11-07 13:38:07 EST
Could somebody please post a patch or something so we can fix it in the 
meantime?
Comment 6 Mike McLean 2002-04-17 16:25:17 EDT
I'm still seeing ip addresses persist on an interface after running ifdown. 
This is happening with recent versions of initscipts, but only when the
BOOTPROTO is dhcp.  After ifdown I see:

# ip addr list dev eth0
2: eth0: <BROADCAST> mtu 1500 qdisc pfifo_fast qlen 100
    link/ether 00:50:da:b4:13:fd brd ff:ff:ff:ff:ff:ff
    inet 192.168.24.4/22 brd 192.168.27.255 scope global eth0

I traced ifdown and it appears that ifdown
  - kills the running dhcpcd process for the interface
  - uses ip link to take the interface down

Neither of these actions seems to remove the ip address from the device.  Is
this a bug in initscripts or in dhcpcd?
Comment 7 Bill Nottingham 2002-04-17 18:12:54 EDT
dhcpcd, I think.

Note You need to log in before you can comment on or make changes to this bug.