Bug 55806 - Will not create partitions based on what is in ks.cfg file
Will not create partitions based on what is in ks.cfg file
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
alpha Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 55805 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-06 17:03 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-13 17:52:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-06 17:03:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
anaconda will not create partitions on redhat 7.1 alpha server based on
what is defined in the ks.cfg file.  It will drop you to manual
partitioning using fdisk or disk druid.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create ks.cfg 
2. start this on alpha system

Expected Results:  auto partitioning of hard drives

Additional info:

ks.cfg file attached

lang en_US
keyboard us
mouse none
timezone --utc America/Los_Angeles
cdrom
network --bootproto static  --ip 192.168.2.250  --netmask 255.255.255.0 
--gateway 192.168.2.1  --nameserver 192.168.2.5
auth --useshadow --enablemd5

firewall --disabled
zerombr no
clearpart --all
part / --size 4000
part swap --size 1000
part /var --size 10 --grow
install

%packages
@Base
@Mail/WWW/News Tools
@Networked Workstation
@NFS Server
@IPX/Netware(tm) Connectivity
@SMB (Samba) Server
Comment 1 Need Real Name 2001-11-06 17:35:24 EST
*** Bug 55805 has been marked as a duplicate of this bug. ***
Comment 2 Brent Fox 2001-11-08 12:20:35 EST
SRM can only boot from BSD partitions.  Therefore, you need to make a /boot
partition of a BSD type in your kickstart file.

So, your partitioning section of the kickstart file needs to look something like:

clearpart --all
part /boot --size 40 --type=9f
part / --size 4000
part swap --size 1000
part /var --size 10 --grow


Does this solve the problem?
Comment 3 Need Real Name 2001-11-09 13:09:08 EST
Now when I start the kickstart install, with the added line to the ks.cfg file, I get a 
invalid literal for int(): 9f.  Then reboots the machine.
Comment 4 Need Real Name 2001-11-12 11:16:14 EST
No, the problem is much worse.  I get a python traceback just after anaconda reads 
the config file, then the machine reboots.
Comment 5 Jeremy Katz 2001-12-12 15:44:12 EST
You need to use the integer form as opposed to 9f (so 159).  Does this work better?
Comment 6 Need Real Name 2001-12-13 17:52:17 EST
Thanks that fixed the problem.

anaconda now kickstart without prompting the installer

Kelly

Note You need to log in before you can comment on or make changes to this bug.