Bug 55810 - 'up2date --test -u' seems to ignore the --test option
'up2date --test -u' seems to ignore the --test option
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 56770 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-06 17:32 EST by Gregory Leblanc
Modified: 2015-01-07 18:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-03 11:57:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Leblanc 2001-11-06 17:32:31 EST
Description of Problem:
I just ran up2date --test -u a moment ago, in order to see what up2date was
going to do if I ran it with the -u flag.  It carried along displaying all
of it's output, and I reviewed all of the messages printed to the console.
 The changes looked fine, so I ran 'up2date -u', which should have actually
installed the packages.  Instead, it told me that there were no new
packages.  When I reviewed the versions of installed pacakges, lo and
behold, the ones that it had told me about with --test were actually
installed. 


Version-Release number of selected component (if applicable):
up2date-2.7.2-7.x.6

Steps to Reproduce:

It's a little hard to try to reproduce this, since there aren't any new
packages to get installed right now.

Additional Information:
I've marked this as "high", but it could conceivably be security related, I
guess.
Comment 1 Adrian Likins 2001-11-06 18:23:50 EST
Well, yeah. The "--test" isnt really intended for a useful purpose (
more of a handy hook for devel time stuff). It wasnt supposed to
even be documented. The new arg parsing stuff autogenerates the
help text though, and it shows "--test" as a valid option. That
wasnt intentional. 

I'll probabaly just remove "--test" entirely, since it doesnt really
do anything. 

Just commited code to remove this option. I might bring it back later
with equilvant function as "--test" of rpm. For now "--list" should
be close enough.
Comment 2 Adrian Likins 2001-12-03 11:57:10 EST
*** Bug 56770 has been marked as a duplicate of this bug. ***
Comment 3 David M. Cook 2002-02-22 12:23:37 EST
Fixed in http://www.redhat.com/support/errata/RHBA-2001-119.html

Note You need to log in before you can comment on or make changes to this bug.