Bug 55820 - Installation failes if /tmp partition is created, following format
Summary: Installation failes if /tmp partition is created, following format
Status: CLOSED DUPLICATE of bug 16686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-07 04:54 UTC by Need Real Name
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 04:54:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-11-07 04:54:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (Win95; I)

Description of problem:
Installation fails with Traceback, at the "Installing Packages" Screen

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select Workstation Install
2. Select Partition with Disk Druid
3. Create /boot, / and /tmp partitions
	

Actual Results:  Fails with traceback an package installation screen.

It appears that the installation procedure is creating a "/tmp" directory and using it as scratchpad and that the "/tmp" partition overmounts that directory 
causing the "scratchpad" to become inaccessible.

Expected Results:  Install packages and complete installation.

Either a warning should be issued, against creating a "/tmp" filesystem, or procedures put in place to allow it's creation without blowing the install.

Additional info:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1470, in doInstall
    self.fstab.turnOnSwap()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 406, in turnOnSwap
    isys.swapon (file)
  File "/usr/lib/anaconda/isys.py", line 142, in swapon
    return _isys.swapon (path)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
path: /tmp/swap/hda6

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3

Comment 1 Brent Fox 2001-11-08 17:07:51 UTC

*** This bug has been marked as a duplicate of 16686 ***


Note You need to log in before you can comment on or make changes to this bug.