Bug 558797 - package-cleanup --problems crashes
package-cleanup --problems crashes
Status: CLOSED DUPLICATE of bug 541551
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-26 08:15 EST by Adam Huffman
Modified: 2014-01-21 18:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-30 06:33:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2010-01-26 08:15:25 EST
Description of problem:
When I run 'package-cleanup --problems' on an F-12 box, it crashes:

package-cleanup --problems
Loaded plugins: fastestmirror, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 382, in <module>
    util = PackageCleanup()
  File "/usr/bin/package-cleanup", line 58, in __init__
    self.main()
  File "/usr/bin/package-cleanup", line 309, in main
    issues = self._find_missing_deps(self.rpmdb.returnPackages())
  File "/usr/bin/package-cleanup", line 137, in _find_missing_deps
    missing = miscutils.formatRequire(req,ver,flags)
  File "/usr/lib/python2.6/site-packages/rpmUtils/miscutils.py", line 350, in formatRequire
    rpm.RPMSENSE_EQUAL):
TypeError: unsupported operand type(s) for &: 'str' and 'int'


Version-Release number of selected component (if applicable):
yum-utils-1.1.24-2.fc12.noarch

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Huffman 2010-01-30 06:33:29 EST

*** This bug has been marked as a duplicate of bug 541551 ***

Note You need to log in before you can comment on or make changes to this bug.