This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 55909 - lpr ceases to print following foomatic, Omni upgrade
lpr ceases to print following foomatic, Omni upgrade
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 11:41 EST by Bryan Headley
Modified: 2005-10-31 17:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 11:29:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
From printconf-tui (1.07 KB, text/plain)
2001-11-09 08:34 EST, Bryan Headley
no flags Details
output from printconf-tui (1.63 KB, text/plain)
2001-11-20 13:07 EST, Need Real Name
no flags Details
LPRng, settings.xml for HP Laser Jet 6L (1.63 KB, text/plain)
2001-11-20 19:48 EST, Need Real Name
no flags Details

  None (edit)
Description Bryan Headley 2001-11-08 11:41:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Print jobs sent to lpr timeout and are never sent to printer.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Omni-0.5.0-4, Omni-foomatic-0.5.0-4, foomatic-1.1.0.20011018.3,
ghostscript-6.51-16, printconf-0.3.52-1, printconf-gui-0.3.52-1
2. Configure printconf for output as ljet
3. ls | lpr does not print anything
	

Actual Results:  If you do an lpq, you note that the print job is in the
queue, but times out. Eventually lprng removes job from queue rather than
print it.

Expected Results:  Some output on the printer.

Additional info:

printconf configured to send postscript to gs, and out as ljet. All jobs
time out and are removed by lprng (rather than print)

Looking at /var/spool/lpd/lp/log yields information that foomatic script is
broken (perl needs 'use utf8;' in it's inline script) Cursory exam shows
several drivers in foomatic affected.

Also: Configured printer for native postscript. It's a LexMark 4039 10R,
which means Postscript 1 (or HPCL 5). Set up printconf for postscript
re-rendering to level 1 PS. Level 2 PostScript being sent to the printer.
This confirmed by watching the printer reset, it's normal reaction to a
Level 2/3-only Postscript command. Have not tracked down where the logic's
breaking down on that.
Comment 1 Crutcher Dunnavant 2001-11-08 22:00:17 EST
Re-render postscript was not set to render to level one, though it will be in
the future. It was just set to pass through psout, so as to render all of the
fonts to postscript bitmaps, to allow japanese fonts to print on non-japanese
postscript printers.

As for the 'use utf8' problem, please be more specific, if you can.
Comment 2 Crutcher Dunnavant 2001-11-08 22:02:52 EST
Specifically, please attach settings.xml from:

printconf-tui --Xexport > settings.xml

To this bug report, so that I can figure out what bit of foomatic is busted for
you. (and which printer you are using ljet for).
Comment 3 Bryan Headley 2001-11-09 08:30:58 EST
perl dumps a message into lp.acct, stating that you must have "use utf8" in the
script.

So, from laserjet-63200.foo:

@@ -223,1 +223,1
-   'cmd' => 'gs -q -dBATCH -dSAFER -dQUIET -dNOPAUSE -sDEVICE=laserjet%A%Z
-sOutputFile=- - | perl -e "my \\$a = join(\'\', <>); \\$a =~s/\\x{1b}E/\\$&%E/;
print \\$a"',
+  'cmd' => 'gs -q -dBATCH -dSAFER -dQUIET -dNOPAUSE -sDEVICE=laserjet%A%Z
-sOutputFile=- - | perl -e "use utf8; my \\$a = join(\'\', <>); \\$a
=~s/\\x{1b}E/\\$&%E/; print \\$a"',
Comment 4 Bryan Headley 2001-11-09 08:34:59 EST
Created attachment 37021 [details]
From printconf-tui
Comment 5 Crutcher Dunnavant 2001-11-09 12:43:17 EST
okay, the culprit is, in fact, perl invoked in the commandline in the foomatic
data. Ick. This requires some nastiyness to fix.

In the meantime, edit the line that starts with "$cmd =" in laserjet-63200.foo
and add 'use utf8;' to the begining of the little perl script.

Garh. This was broken upstream.
Comment 6 Need Real Name 2001-11-20 13:04:46 EST
I have just applied the foomatic-1.1-0.20011018.6.i386.rpm update, however I am
still geeting the same problems that I added to Bug 55022.

Specifically, ljet4 causes the "power on" light on my Lasjet 6L to flash for a
few seconds and then go out. Nothing is printed and the queue is cleared.

I have attached output from printconf-tui to this bug report.
Comment 7 Need Real Name 2001-11-20 13:04:55 EST
I have just applied the foomatic-1.1-0.20011018.6.i386.rpm update, however I am
still geeting the same problems that I added to Bug 55022.

Specifically, ljet4 causes the "power on" light on my Lasjet 6L to flash for a
few seconds and then go out. Nothing is printed and the queue is cleared.

I have attached output from printconf-tui to this bug report.
Comment 8 Need Real Name 2001-11-20 13:07:19 EST
Created attachment 38063 [details]
output from printconf-tui
Comment 9 Need Real Name 2001-11-20 19:48:05 EST
Created attachment 38164 [details]
LPRng, settings.xml for HP Laser Jet 6L
Comment 10 Need Real Name 2001-11-20 19:53:21 EST
Hi,

I just upgraded to the latest foomatic version
foomatic-1.1-0.20011018.6.i386.rpm to get my HP Laser Jet 6L to work.
Unfortunately, I did not succeed. As before, applied all updates especially the
comprehensive printing update, sending the A4 PS Test Page gave no result but
only a short "blink" of the HP's Power LED. Printing the RH text Test Page did
work. Printing with Cups works fine, so I will have to go back to it to get this
printer working :-( My "settings.xml" is attached.
Comment 11 Bryan Headley 2001-11-20 21:07:22 EST
I installed the new RPM. I'm not sure why, but the "cmd" in the laserjet-63200.foo
did NOT have the "perl -Mutf8" (nor my original 'use utf8') in the "gs" command
line. So it stops working again. Cute. I put my fix back into the foo file.

The bug persists. Heh.
Comment 12 Need Real Name 2001-11-21 06:41:45 EST
Including the "fix" Brian Headley supposed above in my laser...foo-file, I am
now able to print PS-files without any problems. Unfortunately, I am still not
able to print text-files. The lights 2 and 3 are blinking which means that the
job is sent to the printer but they are not printed. Hm, silly..., because a 'ls
| lpr' gets printed with a reliable output.
Comment 13 Need Real Name 2001-11-21 08:33:47 EST
In addition to the printing-problem a2ps produces documents that are not readable by ghostview.





a2ps partitionen -o partitionen.ps


gv partitionen.ps 





The ghostscript-messages are:





Error: /undefinedGNU Ghostscript 6.51: Unrecoverable error, exit code 1


 in 15,000000


Operand stack:


   th


Execution stack:


   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--


Dictionary stack:


   --dict:1028/1476(ro)(G)--   --dict:0/20(G)--   --dict:84/200(L)--   -








This does not make sense to me...





My system is a i386-redhat7.2 with all available updates, e.g.





Omni-0.5.0-4


Omni-foomatic-0.5.0-4


foomatic-1.1-0.20011018.6


gv-3.5.8-13


ghostscript-fonts-5.50-3


ghostscript-6.51-16


printconf-gui-0.3.52-1


gnome-print-0.29-6


libgnomeprint15-0.29-6


printconf-0.3.52-1





Also lp does not print this document. It vanishes from queue.





So this problem is not fixed anyways.
Comment 14 Need Real Name 2001-11-21 08:41:25 EST
Sorry for all those empty lines :-(
Comment 15 Philip Long 2001-11-21 10:36:51 EST
Like many others, I applied the patch and hoped for good output.  I'll check out
the contents of /var/spool/lpd/blah tonight and see if I can figure out if it's
still the perl.

I have a HP LJ 5L, and the lj4dithp and ljet4 drivers behave the same way they
did before.  However, the omni print driver now works and sends the job off to
ghostscript and then prints properly (if not quite to the quailty I'd like).
Comment 16 Tim Waugh 2002-01-11 10:56:13 EST
Does this bug still persist with foomatic-1.1-0.20011018.7?
Comment 17 Need Real Name 2002-01-11 13:06:07 EST
It's January 2002, this patch still does not work, meaning that Red Hat Linux 
7.2 does not support printing on dozens of popular printers.

And the priority of this bug is labelled above, as 'normal'.
Comment 18 Tim Waugh 2002-01-18 11:23:50 EST
Please confirm that you are using the foomatic-1.1-0.20011018.7 package, 
rather than the earlier one mentioned (.6).  I think you imply that you are, 
but please be explicit so that I know. (The .7 package clears out the cache 
properly, so that would rule out problems of stale caches.)

I think I may have seen a way of fixing the problem, if it is what I think it 
is, earlier today.  Once I've done some more testing, and if it works, I'll 
put a note here with a pointer to a package with the fix for wider testing.

Briefly, instead of '\x{1b}' we should be using '\x1b' in the perl script, and 
not using -Mutf8 at all.
Comment 19 Tim Waugh 2002-01-18 13:19:09 EST
Okay, please give these packages a try:

ftp://people.redhat.com/twaugh/errata-candidate/i386/
  printconf-0.3.61-1.1.i386.rpm
  printconf-gui-0.3.61-1.1.i386.rpm
  foomatic-1.1-0.20011218-1.3.i386.rpm

(SRPMS in ../SRPMS)

Let me know if these produce any better results.
Comment 20 Tim Waugh 2002-01-18 16:28:13 EST
I've replaced the foomatic errata with a newer one:

  foomatic-1.1-0.20011218-1.4.i386.rpm

Comment 21 Need Real Name 2002-01-19 19:50:10 EST
I've just tried the new RPMs provided and can confirm that my HP LaserJet 6L
works perfectly with the "ljet4" driver!

Just to confirm, the files I've used are:

printconf-0.3.61-1.1.i386.rpm
printconf-gui-0.3.61-1.1.i386.rpm
foomatic-1.1-0.20011218.1.4.i386.rpm

Available here: ftp://people.redhat.com/twaugh/errata-candidate/

Many, many thanks Mr Waugh!
Comment 22 Tim Waugh 2002-02-08 03:58:51 EST
Fixed by RHBA-2001:174.

Note You need to log in before you can comment on or make changes to this bug.