Bug 55921 - Grub breaks APM with Windows 98 & ME
Grub breaks APM with Windows 98 & ME
Status: CLOSED DUPLICATE of bug 54375
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 14:50 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-08 14:52:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-08 14:50:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT; Aztec)

Description of problem:
The grub boot loader causes Windows98SE and WinME to not be able to detect 
or use APM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH7.2 with grub on an Dell Inspiron laptop (other computers with 
APM bios might work also) with both Linux and Windows as boot options 
2.Boot up and select Windows from the grub interface
3.Go to Window's device manager and observe broken APM support
	

Actual Results:  APM support not working under Windows 98 and ME.  Error 
code 10 reported by windows device manager

Expected Results:  Windows should work with the APM bios.

Additional info:
Comment 1 Need Real Name 2001-11-08 14:52:39 EST
I believe this problem has been discussed on the grub mailing list and might be 
fixed in the latest version of grub.
Comment 2 Jeremy Katz 2001-11-08 14:59:26 EST
It's fixed in GRUB CVS and our current packages have the fix included.  Updated
packages with the fix can be found at http://people.redhat.com/~katzj/RPMS/

*** This bug has been marked as a duplicate of 54375 ***

Note You need to log in before you can comment on or make changes to this bug.