Bug 55927 - migrate_*.pl scripts - Data error from protocols/services
migrate_*.pl scripts - Data error from protocols/services
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-08 16:51 EST by Matt
Modified: 2014-08-31 19:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:17:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt 2001-11-08 16:51:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:

Several data errors were encountered when running the 
migrate_all_online.pl scripts.  It appears they have to do with + signs in 
names and duplicate names.

[root@gordon migration]# cat bugs.txt

Duplicate Protocol Names..

st      5       ST              # ST datagram mode
st     118     ST             # Schedule Transfer

Plus symbols in the protocol name..

ttp++     84      TTP++             # TTP

Duplicate Service Names:

adding new entry
"cn=support+ipServiceProtocol=tcp,ou=Services,dc=yellowguppy,dc
=com"
ldap_add: Already exists

ldif_record() = 68
/usr/bin/ldapadd: returned non-zero exit status

Plus symbols in the service name..

adding new entry
"cn=whois+++ipServiceProtocol=tcp,ou=Services,dc=yellowguppy,dc
=com"
ldap_add: Invalid DN syntax
        additional info: invalid DN

ldif_record() = 34
/usr/bin/ldapadd: returned non-zero exit status
[root@gordon migration]#

[root@gordon migration]# cat /etc/redhat-release
Red Hat Linux release 7.1 (Seawolf)
[root@gordon migration]# uname -a
Linux gordon 2.4.9-6 #1 Thu Oct 18 09:22:43 EDT 2001 i586 unknown
[root@gordon migration]# rpm -qa | grep "openldap"
openldap-servers-2.0.11-8
openldap-2.0.11-8
openldap-clients-2.0.11-8
openldap-devel-2.0.11-8
[root@gordon migration]#

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run the files -> ldap migration scripts..
2. Encounter the errors..
3.
	

Actual Results:  Errors generated..

Additional info:

Would be nice to have rollback scripts to delete the converted OU objects 
or check/delete the objects after the failure of the first scripts.
Comment 1 John Dalbec 2001-11-29 16:44:01 EST
The duplicates are gone in 7.2.  Unfortunately the ++ are not.  Much of the pain caused by this issue can be relieved by editing your favorite 
migrate_all_* script and changing

if [ "X$LDAPADD" = "X" ]; then
        if [ -x ldapadd ]; then
                LDAPADD=ldapadd
        elif [ -x /usr/local/bin/ldapadd ]; then
                LDAPADD="/usr/local/bin/ldapadd"
        elif [ -x /usr/bin/ldapadd ]; then
                LDAPADD="/usr/bin/ldapadd"
        elif [ -x "$NSHOME/bin/slapd/server/ldapmodify" ]; then
                LDAPADD="$NSHOME/bin/slapd/server/ldapmodify -a -c"
        elif [ -x "/opt/IIIdds/bin/ldapmodify" ]; then
                LDAPADD="/opt/IIIdds/bin/ldapmodify -a -c"
        fi
fi

to

if [ "X$LDAPADD" = "X" ]; then
        if [ -x ldapadd ]; then
                LDAPADD="ldapadd -c"  #  changed
        elif [ -x /usr/local/bin/ldapadd ]; then
                LDAPADD="/usr/local/bin/ldapadd -c"  #  changed
        elif [ -x /usr/bin/ldapadd ]; then
                LDAPADD="/usr/bin/ldapadd -c"  #  changed
        elif [ -x "$NSHOME/bin/slapd/server/ldapmodify" ]; then
                LDAPADD="$NSHOME/bin/slapd/server/ldapmodify -a -c"
        elif [ -x "/opt/IIIdds/bin/ldapmodify" ]; then
                LDAPADD="/opt/IIIdds/bin/ldapmodify -a -c"
        fi
fi

The "-c" at the end tells it to skip over errors and continue processing the remaining records.
Comment 2 Graham Freeman 2002-12-09 19:12:08 EST
The "++" problem is still present in Red Hat 8.0
Comment 3 Chan Min Wai 2004-02-03 03:14:39 EST
I think this most suit what I want to report...

Import log (/migrate_all_online.sh)
...
adding new entry "cn=echo,ou=Services,dc=amtb-m,dc=int"
adding new entry "cn=rje,ou=Services,dc=amtb-m,dc=int"
adding new entry "cn=zip,ou=Services,dc=amtb-m,dc=int"
adding new entry "cn=echo,ou=Services,dc=amtb-m,dc=int"
ldapadd: update failed: cn=echo,ou=Services,dc=amtb-m,dc=int
ldap_add: Already exists (68)
There are a double entry on cn=echo , cn=nextstep and cn=cvsup.

Hope there is a way to solve this problem.
Comment 4 Kenneth Porter 2005-05-25 22:07:08 EDT
Seeing this importing services on Fedora Core 2, starting with echo. Haven't
traced exactly what the issue is, yet. echo is listed in /etc/services under 3
protocols, UDP, TCP, and Apple's DDP.
Comment 5 Kenneth Porter 2005-05-25 22:34:18 EDT
Plus signs are correctly handled at least as of FC2, escaped by the
migrate_services.pl script. However, the echo/ddp entry is not. See bug 132261
and bug 126711 for an explanation of the latter.
Comment 6 Bill Nottingham 2006-08-07 15:57:25 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 7 Bill Nottingham 2006-10-18 13:17:11 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.