Bug 55947 - cdrom failure after install
cdrom failure after install
Status: CLOSED DUPLICATE of bug 55071
Product: Red Hat Linux
Classification: Retired
Component: cdrtools (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Depends On:
  Show dependency treegraph
Reported: 2001-11-09 05:31 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-12 08:10:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-09 05:31:04 EST
After installation off a cdrom device Redhat 7.2 does not seem to have the device installed. The problem does not arise in 7.1.....

The hardware is amd k6 chip
128 mb ram

The install has no errors but after install the cdrom will not mount manually or from the desk top link....

the error is mount dev/cdrom is not a valid block device..
the hardware browser shows no cdrom installed...

Same set of disks are fine on other hardware components...(ie pentium)
thanks willem
Comment 1 Riku Seppala 2001-11-10 13:16:38 EST
I have the same problem. I have k6-2, M577 motherboard, Ricoh 9120a DVD/CD-RW
compo drive as secondary slave and I cant mount cdrom. It worked fine on RH 7.1

I think this is the same bug as 55218
Comment 2 Marco Ostini 2001-11-12 01:46:29 EST
My P233 MMX Gateway E1000 with 64Mb also has the same problem after having been 
upgraded from RH 7.1

/dev/cdrom is not a valid block device

is reported when attempting to mount although the hardware is fine.

dmesg shows the flolwing:

hda: ST310212A, ATA DISK drive
hdc: CD-ROM CDU4011, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 20005650 sectors (10243 MB) w/512KiB Cache, CHS=1245/255/63, UDMA(33)
ide-floppy driver 0.97

Every time mounting the CD Rom is attempted, it fails, with the following message 
added to the end of Dmesg:

hdc: driver not present
ide-floppy driver 0.97 
Comment 3 Bruce D. Meyer 2001-11-12 08:10:20 EST
I have installed RH7.2 on three seperate machine Intel P-III 550 with one CD, 
Pentium 200 (I586), with one CD, and AMD K6-3/450 with one CD, one CD-RW.

The i586 install is CLI only, no X, KDE or Gnmoe etc, and has the same problem 
as the others. Entering :
mount /mnt/cdrom
gets a response of 'invalid block device'
mount -t iso9660 /dev/cdrom /mnt/cdrom
I swapped out the CDROM drives with three other known functional CD Drives, and 
used various CD's known to be good, inclucing the original install media and I 
get error with each permutation.
Reinstalling RH7.1 works perfectly on the same hardware.

Bruce Meyer
Comment 4 Bill Nottingham 2001-11-12 09:36:22 EST

*** This bug has been marked as a duplicate of 55071 ***

Note You need to log in before you can comment on or make changes to this bug.