Bug 559572 - Brightness does not work with Intel Mobile 945GM/GMS, 943/940GML
Brightness does not work with Intel Mobile 945GM/GMS, 943/940GML
Status: CLOSED DUPLICATE of bug 572896
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-28 09:20 EST by Fabian Deutsch
Modified: 2010-03-12 06:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-12 06:49:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2010-01-28 09:20:21 EST
Description of problem:
I can not adjust the brightness on my MacBook

Version-Release number of selected component (if applicable):
Actually I do not know which component is responsible ...

$ rpm -qa | egrep -i "(kernel|acpi|xorg)" | sort
dracut-kernel-004-1.fc13.noarch
kernel-2.6.31.5-127.fc12.i686
kernel-2.6.32.3-21.fc13.i686
kernel-2.6.33-0.23.rc5.git1.fc13.i686
kernel-devel-2.6.31.5-127.fc12.i686
kernel-devel-2.6.32.3-21.fc13.i686
kernel-devel-2.6.33-0.23.rc5.git1.fc13.i686
kernel-headers-2.6.33-0.23.rc5.git1.fc13.i686
xorg-x11-apps-7.4-9.fc13.i686
xorg-x11-drivers-7.3-13.fc12.i686
xorg-x11-drv-acecad-1.4.0-3.fc13.i686
xorg-x11-drv-aiptek-1.3.0-3.fc13.i686
xorg-x11-drv-apm-1.2.2-1.fc12.i686
xorg-x11-drv-ast-0.89.9-1.fc12.i686
xorg-x11-drv-ati-6.13.0-0.20.20100125gitba99a82ce.fc13.i686
xorg-x11-drv-cirrus-1.3.2-2.fc13.i686
xorg-x11-drv-dummy-0.3.3-2.fc13.i686
xorg-x11-drv-elographics-1.2.3-6.fc13.i686
xorg-x11-drv-evdev-2.3.99-2.20100108.fc13.i686
xorg-x11-drv-fbdev-0.4.1-3.fc13.i686
xorg-x11-drv-fpit-1.3.0-5.fc13.i686
xorg-x11-drv-geode-2.11.4.1-2.fc13.i686
xorg-x11-drv-glint-1.2.4-2.fc13.i686
xorg-x11-drv-hyperpen-1.3.0-4.fc13.i686
xorg-x11-drv-i128-1.3.3-2.fc13.i686
xorg-x11-drv-i740-1.3.2-2.fc13.i686
xorg-x11-drv-intel-2.10.0-2.fc13.i686
xorg-x11-drv-keyboard-1.4.0-4.fc13.i686
xorg-x11-drv-mach64-6.8.2-2.fc13.i686
xorg-x11-drv-mga-1.4.11-2.fc13.i686
xorg-x11-drv-mouse-1.5.0-4.fc13.i686
xorg-x11-drv-mutouch-1.2.1-6.fc13.i686
xorg-x11-drv-neomagic-1.2.4-3.fc13.i686
xorg-x11-drv-nouveau-0.0.15-17.20091105gite1c2efd.fc12.i686
xorg-x11-drv-nv-2.1.15-5.fc13.i686
xorg-x11-drv-openchrome-0.2.904-2.fc13.i686
xorg-x11-drv-penmount-1.4.0-6.fc13.i686
xorg-x11-drv-r128-6.8.1-3.fc13.i686
xorg-x11-drv-rendition-4.2.2-5.fc13.i686
xorg-x11-drv-s3virge-1.10.4-2.fc13.i686
xorg-x11-drv-savage-2.3.1-2.fc13.i686
xorg-x11-drv-siliconmotion-1.7.3-3.20100122.fc13.i686
xorg-x11-drv-sis-0.10.2-2.fc13.i686
xorg-x11-drv-sisusb-0.9.3-2.fc13.i686
xorg-x11-drv-synaptics-1.2.0-4.fc13.i686
xorg-x11-drv-tdfx-1.4.3-2.fc13.i686
xorg-x11-drv-trident-1.3.3-2.fc13.i686
xorg-x11-drv-v4l-0.2.0-4.fc13.1.i686
xorg-x11-drv-vesa-2.2.1-2.fc13.i686
xorg-x11-drv-vmmouse-12.6.5-4.fc13.i686
xorg-x11-drv-vmware-10.16.7-3.fc13.i686
xorg-x11-drv-void-1.3.0-5.fc13.i686
xorg-x11-drv-voodoo-1.2.3-2.fc13.i686
xorg-x11-drv-wacom-0.10.4-1.fc13.i686
xorg-x11-fonts-misc-7.2-9.fc12.noarch
xorg-x11-font-utils-7.2-11.fc13.i686
xorg-x11-proto-devel-7.4-35.fc13.noarch
xorg-x11-server-common-1.7.99.3-1.20100120.fc13.i686
xorg-x11-server-devel-1.7.99.3-1.20100120.fc13.i686
xorg-x11-server-utils-7.4-15.fc13.i686
xorg-x11-server-Xorg-1.7.99.3-1.20100120.fc13.i686
xorg-x11-util-macros-1.4.1-1.fc13.noarch
xorg-x11-utils-7.4-8.fc13.i686
xorg-x11-xauth-1.0.2-7.fc12.i686
xorg-x11-xinit-1.0.9-13.fc13.i686
xorg-x11-xkb-utils-7.4-7.fc13.i686

How reproducible:
Get a MacBook (first generation white)

Steps to Reproduce:
1. Install fedora
2. Try to use GNOMEs brightness applet
3.
  
Actual results:
Nothing happens

Expected results:
Brightness changes

Additional info:
It work when I initially installed Fedora 11
Comment 1 Michal Schmidt 2010-03-12 05:10:42 EST
Possibly a duplicate of bug 572896. Here's a scratch build of gnome-power-manager for i686: http://koji.fedoraproject.org/koji/taskinfo?taskID=2048407 . Please test it and if it helps, close this bug as a duplicate of 572896.
Comment 2 Fabian Deutsch 2010-03-12 06:34:50 EST
Yes - Great! - it fixes this long standing bug :)
And my battery makes sense again ...
Comment 3 Michal Schmidt 2010-03-12 06:49:13 EST
Thank you for testing.

*** This bug has been marked as a duplicate of bug 572896 ***

Note You need to log in before you can comment on or make changes to this bug.