Bug 572896 - gnome-power-manager is built without HAL brightness support
gnome-power-manager is built without HAL brightness support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 559572 572005 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-12 04:42 EST by Michal Schmidt
Modified: 2010-03-19 23:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: gnome-power-manager-2.29.91-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-19 23:38:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2010-03-12 04:42:34 EST
Description of problem:
gnome-power-manager-2.29.91-2.fc13 was supposed to re-enable HAL support, but it failed to do that. From build.log:
   HAL (brightness) support:  no

To build gnome-power-manager with HAL support, '--enable-hal' must be passed to configure.
(BTW, the current spec file passes the parameter '--enable-policykit' which is not recognized by configure, so it can be removed.)

When you add '--enable-hal', you'll notice it does not compile anymore because of a trivial error. This commit in upstream git fixes it:

commit fdcf156c85c10a6053b7364d882611df07000343
Author: Chris Coulson
Date:   Tue Mar 2 08:59:31 2010 +0000

    Declare GError in gpm_brightness_hal_init to fix build failure

I made a scratch build and tested that it works fine then: http://koji.fedoraproject.org/koji/taskinfo?taskID=2048364

Version-Release number of selected component (if applicable):
gnome-power-manager-2.29.91-2.fc13

How reproducible:
always

Steps to Reproduce:
1. Test on a system where there's no brightness property in xrandr.
2. Try to change brightness using hotkeys, or try to find a brightness slider gnome-power-preferences
  
Actual results:
Brightness cannot be changed, there's no slider.

Expected results:
Brightness hotkeys work, there's a slider in g-p-preferences.
Comment 1 Michal Schmidt 2010-03-12 06:49:13 EST
*** Bug 559572 has been marked as a duplicate of this bug. ***
Comment 2 Nigel Jones 2010-03-12 07:11:04 EST
I am still unable to change brightness using
[jonesn@snowdon2 ~]$ rpm -q gnome-power-manager
gnome-power-manager-2.29.91-2.fc13.x86_64


This worked initially. will refer to dup bug ref.
Comment 3 Michal Schmidt 2010-03-12 08:01:53 EST
Nigel, gnome-power-manager-2.29.91-2.fc13.x86_64 is known to have the bug.
The scratch build with the fix has ".m1" in the release field.
Comment 4 Nigel Jones 2010-03-12 08:21:52 EST
Many thanks. Id missed the m1. Duh!

The build works great - brightness control now fine again -- thanks.
Comment 5 Tommy He 2010-03-12 09:20:38 EST
*** Bug 572005 has been marked as a duplicate of this bug. ***
Comment 6 Tommy He 2010-03-12 09:26:20 EST
Thanks for fixing.

I missed the m1 , too.
Comment 7 Fedora Update System 2010-03-15 07:43:01 EDT
gnome-power-manager-2.29.91-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnome-power-manager-2.29.91-3.fc13
Comment 8 Fedora Update System 2010-03-15 20:42:28 EDT
gnome-power-manager-2.29.91-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-power-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gnome-power-manager-2.29.91-3.fc13
Comment 9 Fedora Update System 2010-03-19 23:38:07 EDT
gnome-power-manager-2.29.91-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.