Bug 559844 - udev update needs edits in rules
udev update needs edits in rules
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 01:56 EST by Michal Jaegermann
Modified: 2010-06-25 07:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: udev-151-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 07:49:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
complaints from udev after the current update (1.12 KB, text/plain)
2010-01-29 01:56 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2010-01-29 01:56:06 EST
Created attachment 387509 [details]
complaints from udev after the current update

Description of problem:

After an update of udev attached messages show up while booting a machine.  True, some of these belong to packages other than udev but even own udev rules are affected so other are not such surprising.

Moreover later during a boot this shows up: "Retrigger failed udev eventstrigger: unrecognized option '--retry-failed'".  Not obvious to me what is causing that as attempts to repeat that after a boot is complete were not successful.  

Version-Release number of selected component (if applicable):
udev-151-1.fc13

How reproducible:
on every startup

Expected results:
udev happy with its rules
Comment 1 Harald Hoyer 2010-01-29 04:06:25 EST
# repoquery -f /etc/udev/rules.d/56-hpmud_support.rules
hplip-common

# repoquery -f /lib/udev/rules.d/88-clock.rules 
initscripts

# repoquery -f /lib/udev/rules.d/40-redhat.rules
udev
Comment 2 Harald Hoyer 2010-01-29 04:58:03 EST
should be fixed in udev-151-2
Comment 3 Clyde E. Kunkel 2010-01-29 16:59:48 EST
udev-151-2 did not fix for me, but may be a different error as I see msgs about something being removed in a future release, then the system stops (keyboard still alive) after Intel microcode msg.  Had to revert udev et al to 147-2.fc13.x86_64 to get running system.  Could boot to single with 151-1 and 151-2 tho.
Comment 4 Michal Jaegermann 2010-01-30 20:39:38 EST
After an update to udev-151-2.fc13.x86_64 I see now
"Retrigger failed udev events" and "[  OK  ]".  It looks that this is like it is supposed to be and it comes from a udev-post service.  Still seeing "failed" in a boot sequence is not something one would like. :-)  Hm, maybe replacing here "failed" with "outlaying" would be less jarring?

Rule complaints generated by udev are also gone although those caused by other package remain.  Does this require separate bug filings?
Comment 5 Harald Hoyer 2010-02-01 07:40:51 EST
(In reply to comment #4)
> After an update to udev-151-2.fc13.x86_64 I see now
> "Retrigger failed udev events" and "[  OK  ]".  It looks that this is like it
> is supposed to be and it comes from a udev-post service.  Still seeing "failed"
> in a boot sequence is not something one would like. :-)  Hm, maybe replacing
> here "failed" with "outlaying" would be less jarring?

hehe, yes, ok

> 
> Rule complaints generated by udev are also gone although those caused by other
> package remain.  Does this require separate bug filings?    

yes, please
Comment 6 Harald Hoyer 2010-02-01 07:43:19 EST
(In reply to comment #3)
> udev-151-2 did not fix for me, but may be a different error as I see msgs about
> something being removed in a future release, then the system stops (keyboard
> still alive) after Intel microcode msg.  Had to revert udev et al to
> 147-2.fc13.x86_64 to get running system.  Could boot to single with 151-1 and
> 151-2 tho.    

can you disable the "microcode" service and retry with 151 ?
Comment 7 Clyde E. Kunkel 2010-02-01 10:37:02 EST
151-2 works for me with microcode service disabled.  Now just seeing a series of udev msgs like:

udevd[896]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/56-hpmud_support.rules:10




udevd[896]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:3




udevd[896]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:3

etc, etc.
Comment 8 Harald Hoyer 2010-02-01 10:50:10 EST
see bug #560031 for the microcode problem

Please file a bug for the packages of the rules files, which give a warning.
Comment 9 Michal Jaegermann 2010-02-01 14:15:09 EST
(In reply to comment #1)
> # repoquery -f /etc/udev/rules.d/56-hpmud_support.rules
> hplip-common
Bug 560754.

> # repoquery -f /lib/udev/rules.d/88-clock.rules 
> initscripts
Bug 560756.
Comment 10 Bug Zapper 2010-03-15 10:16:45 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Jonathan 2010-03-20 17:39:02 EDT
Think I need to be added to this bug as well. Here's the boot message


Starting udev: udevd[389]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:3




udevd[389]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:3




udevd[389]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/85-pcscd_egate.rules:5



udev-151-3-.fc13.i686

It's running my hard drives at 33mhz when one is 133 mhz and one is 100mhz IDE interface. Also running IDE 66mhz dvd writer at 33mhz.

Here's the relevant boot info.
Mar 20 15:06:41 localhost kernel: ata2.00: ATAPI: PIONEER DVD-RW  DVR-111D, 1.29, max UDMA/66
Mar 20 15:06:41 localhost kernel: ata2.00: limited to UDMA/33 due to 40-wire cable
Mar 20 15:06:41 localhost kernel: ata1.00: HPA detected: current 156299375, native 156301488
Mar 20 15:06:41 localhost kernel: ata1.00: ATA-5: WDC WD800JB-00CRA1, 17.07W17, max UDMA/100
Mar 20 15:06:41 localhost kernel: ata1.00: 156299375 sectors, multi 16: LBA 
Mar 20 15:06:41 localhost kernel: ata2.00: configured for UDMA/33
Mar 20 15:06:41 localhost kernel: ata1.01: HPA detected: current 160084415, native 160086528
Mar 20 15:06:41 localhost kernel: ata1.01: ATA-7: Maxtor 6Y080P0, YAR41BW0, max UDMA/133
Mar 20 15:06:41 localhost kernel: ata1.01: 160084415 sectors, multi 16: LBA 
Mar 20 15:06:41 localhost kernel: ata1.00: limited to UDMA/33 due to 40-wire cable
Mar 20 15:06:41 localhost kernel: ata1.01: limited to UDMA/33 due to 40-wire cable
Mar 20 15:06:41 localhost kernel: ata1.00: configured for UDMA/33
Mar 20 15:06:41 localhost kernel: ata1.01: configured for UDMA/33
Mar 20 15:06:41 localhost kernel: scsi 0:0:0:0: Direct-Access     ATA      WDC WD800JB-00CR 17.0 PQ: 0 ANSI: 5
Mar 20 15:06:41 localhost kernel: sd 0:0:0:0: [sda] 156299375 512-byte logical blocks: (80.0 GB/74.5 GiB)
Mar 20 15:06:41 localhost kernel: sd 0:0:0:0: [sda] Write Protect is off
Mar 20 15:06:41 localhost kernel: sd 0:0:0:0: Attached scsi generic sg0 type 0
Mar 20 15:06:41 localhost kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Mar 20 15:06:41 localhost kernel: scsi 0:0:1:0: Direct-Access     ATA      Maxtor 6Y080P0   YAR4 PQ: 0 ANSI: 5
Mar 20 15:06:41 localhost kernel: sda:
Mar 20 15:06:41 localhost kernel: sd 0:0:1:0: Attached scsi generic sg1 type 0
Mar 20 15:06:41 localhost kernel: scsi 1:0:0:0: CD-ROM            PIONEER  DVD-RW  DVR-111D 1.29 PQ: 0 ANSI: 5
Mar 20 15:06:41 localhost kernel: sda1 sda2
Mar 20 15:06:41 localhost kernel: sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
Mar 20 15:06:41 localhost kernel: Uniform CD-ROM driver Revision: 3.20
Mar 20 15:06:41 localhost kernel: sr 1:0:0:0: Attached scsi generic sg2 type 5
Mar 20 15:06:41 localhost kernel: sd 0:0:1:0: [sdb] 160084415 512-byte logical blocks: (81.9 GB/76.3 GiB)
Mar 20 15:06:41 localhost kernel: sd 0:0:1:0: [sdb] Write Protect is off
Mar 20 15:06:41 localhost kernel: sd 0:0:1:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Mar 20 15:06:41 localhost kernel: sd 0:0:0:0: [sda] Attached SCSI disk

System is gigabyte GA-8IK1100 motherboard based on Intel ICH5R and Intel 875P chipset.

Note You need to log in before you can comment on or make changes to this bug.