Bug 559919 - yum-builddep AttributeError: Values instance has no attribute 'source'
yum-builddep AttributeError: Values instance has no attribute 'source'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 560120 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 05:49 EST by Mads Kiilerich
Modified: 2014-01-21 18:13 EST (History)
8 users (show)

See Also:
Fixed In Version: yum-utils-1.1.27-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 13:21:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2010-01-29 05:49:51 EST
[root@localhost ~]# yum clean all
Loaded plugins: dellsysidplugin2, fastestmirror, merge-conf, presto,
              : refresh-packagekit, remove-with-leaves
Cleaning up Everything
Cleaning up list of fastest mirrors
0 delta-package files removed, by presto

[root@localhost ~]# yum-builddep --disablerepo=* --enablerepo=fedora* --enablerepo=updates* nautilus-python
Loaded plugins: dellsysidplugin2, fastestmirror, presto, refresh-
              : packagekit, remove-with-leaves
Determining fastest mirrors
fedora/metalink                                |  29 kB     00:00     
updates/metalink                               |  16 kB     00:00     
updates-testing/metalink                       |  14 kB     00:00     
 * fedora: ftp.klid.dk
 * fedora-debuginfo: ftp.klid.dk
 * fedora-source: ftp.crc.dk
 * updates: ftp.klid.dk
 * updates-debuginfo: ftp.klid.dk
 * updates-source: ftp.klid.dk
 * updates-testing: ftp.klid.dk
 * updates-testing-debuginfo: ftp.klid.dk
 * updates-testing-source: ftp.klid.dk
fedora                                         | 4.2 kB     00:00     
fedora/primary_db                              | 9.7 MB     00:00     
updates                                        | 4.4 kB     00:00     
updates/primary_db                             | 2.9 MB     00:00     
updates-testing                                | 4.4 kB     00:00     
updates-testing/primary_db                     | 960 kB     00:00     
Checking for new repos for mirrors
Enabling fedora-source repository
Enabling updates-source repository
Enabling updates-testing-source repository
Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 196, in <module>
    util = YumBuildDep()
  File "/usr/bin/yum-builddep", line 64, in __init__
    self.main()
  File "/usr/bin/yum-builddep", line 93, in main
    self.get_build_deps(opts)
  File "/usr/bin/yum-builddep", line 169, in get_build_deps
    toActOn.extend(_best_convert_pkg2srcpkgs(self, opts, newpkg))
  File "/usr/bin/yum-builddep", line 40, in _best_convert_pkg2srcpkgs
    if not opts.source or pkg.arch == 'src':
AttributeError: Values instance has no attribute 'source'

[root@localhost ~]# rpm -qa rpm* yum*|sort
rpm-4.7.2-1.fc12.i686
rpm-build-4.7.2-1.fc12.i686
rpm-devel-4.7.2-1.fc12.i686
rpmdevtools-7.5-1.fc12.noarch
rpmfusion-free-release-12-1.noarch
rpmfusion-free-remix-kickstarts-0.11.1-5.fc11.noarch
rpmfusion-nonfree-release-12-1.noarch
rpmfusion-nonfree-remix-kickstarts-0.11.1-5.fc11.noarch
rpm-libs-4.7.2-1.fc12.i686
rpmlint-0.93-2.fc12.noarch
rpm-python-4.7.2-1.fc12.i686
yum-3.2.25-1.fc12.noarch
yum-metadata-parser-1.1.2-14.fc12.i686
yum-plugin-fastestmirror-1.1.25-1.fc12.noarch
yum-plugin-merge-conf-1.1.25-1.fc12.noarch
yum-plugin-remove-with-leaves-1.1.25-1.fc12.noarch
yum-presto-0.6.2-1.fc12.noarch
yum-utils-1.1.25-1.fc12.noarch
[root@localhost ~]#
Comment 2 Mads Kiilerich 2010-01-29 17:18:23 EST
*** Bug 560120 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-06-06 09:45:06 EDT
yum-utils-1.1.27-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/yum-utils-1.1.27-1.fc13
Comment 4 Fedora Update System 2010-06-08 15:35:31 EDT
yum-utils-1.1.27-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/yum-utils-1.1.27-2.fc13
Comment 5 Fedora Update System 2010-06-14 13:20:28 EDT
yum-utils-1.1.27-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.