Bug 560120 - [abrt] crash in yum-utils-1.1.25-1.fc12
[abrt] crash in yum-utils-1.1.25-1.fc12
Status: CLOSED DUPLICATE of bug 559919
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:1a00a3c0
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 17:16 EST by Mads Kiilerich
Modified: 2014-01-21 18:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-29 17:18:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.35 KB, text/plain)
2010-01-29 17:16 EST, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2010-01-29 17:16:44 EST
abrt 1.0.4 detected a crash.

architecture: i686
cmdline: /usr/bin/python -tt /usr/bin/yum-builddep nautilus-python
component: yum-utils
executable: /usr/bin/yum-builddep
kernel: 2.6.32.3-24.fc12.i686.PAE
package: yum-utils-1.1.25-1.fc12
release: Fedora release 12 (Constantine)

backtrace
-----
Summary: TB1a00a3c0 yum-builddep:40:_best_convert_pkg2srcpkgs:AttributeError: Values instance has no attribute 'source'

Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 196, in <module>
    util = YumBuildDep()
  File "/usr/bin/yum-builddep", line 64, in __init__
    self.main()
  File "/usr/bin/yum-builddep", line 93, in main
    self.get_build_deps(opts)
  File "/usr/bin/yum-builddep", line 169, in get_build_deps
    toActOn.extend(_best_convert_pkg2srcpkgs(self, opts, newpkg))
  File "/usr/bin/yum-builddep", line 40, in _best_convert_pkg2srcpkgs
    if not opts.source or pkg.arch == 'src':
AttributeError: Values instance has no attribute 'source'

Local variables in innermost frame:
self: <__main__.YumBuildDep object at 0x904db0c>
pkg: <YumAvailablePackageSqlite : nautilus-python-0.5.1-5.fc12.i686 (0xb82c5cc)>
opts: <Values at 0x90d412c: {'skipbroken': None, 'verbose': None, 'errorlevel': None, 'color': None, 'repos': [], 'conffile': '/etc/yum/yum.conf', 'exclude': [], 'enableplugins': [], 'tolerant': None, 'cacheonly': None, 'disableplugins': [], 'sleeptime': None, 'version': None, 'obsoletes': None, 'debuglevel': None, 'disableexcludes': [], 'nogpgcheck': None, 'showdupesfromrepos': None, 'assumeyes': None, 'disablepresto': False, 'installroot': None, 'quiet': None, 'exclude_bin': False, 'remove_leaves': False, 'noplugins': None}>
Comment 1 Mads Kiilerich 2010-01-29 17:16:46 EST
Created attachment 387658 [details]
File: backtrace
Comment 2 Mads Kiilerich 2010-01-29 17:18:23 EST

*** This bug has been marked as a duplicate of bug 559919 ***

Note You need to log in before you can comment on or make changes to this bug.