Bug 559975 - No ramdisk created for installed system - which: no multipath in (/sbin:/bin:/usr/sbin:/usr/bin)
Summary: No ramdisk created for installed system - which: no multipath in (/sbin:/bin:...
Keywords:
Status: CLOSED DUPLICATE of bug 559597
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F13Alpha, F13AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-01-29 14:32 UTC by James Laska
Modified: 2013-09-02 06:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-29 15:42:10 UTC


Attachments (Terms of Use)
/tmp/anaconda-logs.tgz (/tmp/*log) (39.18 KB, application/x-compressed-tar)
2010-01-29 14:32 UTC, James Laska
no flags Details

Description James Laska 2010-01-29 14:32:43 UTC
Created attachment 387580 [details]
/tmp/anaconda-logs.tgz (/tmp/*log)

Description of problem:

After installing Rawhide, the grub.conf created does not contain a ramdisk.  Closer inspection shows no ramdisk file exists.  If I chroot into the filesystem and run dracut by hand, an initramfs is *not* built.  So somehow, initramfs creation is failing.

Version-Release number of selected component (if applicable):
 * anaconda-13.23
 * dracut-004-1.fc13.noarch

How reproducible:
 * so far, 4 out of 4 attempts

Steps to Reproduce:
1. Install to virt-guest using vmlinuz+initrd.img+install.img from http://alt.fedoraproject.org/pub/alt/stage/rawhide-testing/

 OR 

1. Run dracut /boot/initramfs-$(uname -r).img $(uname -r)
  
Actual results:

No file /boot/initramfs-$(uname -r).img is created.  I see the following stdout

which: no multipath in (/sbin:/bin:/usr/sbin:/usr/bin)
E: Failed to install /lib/udev/firmware.sh

Expected results:

Initramfs created

Additional info:
 * See anaconda-logs.tgz (/tmp/*log* if desired.

Comment 1 James Laska 2010-01-29 14:52:10 UTC
After chrooting into the installed system and running ...

 # yum install device-mapper-multipath
 # dracut /boot/initramfs-$(uname -r).img $(uname -r)
E: Failed to install /lib/udev/firmware.sh

A ramdisk hasn't been created.  So I guess the multipath stderr wasn't the culrprit.

Comment 2 Harald Hoyer 2010-01-29 15:42:10 UTC

*** This bug has been marked as a duplicate of bug 559597 ***


Note You need to log in before you can comment on or make changes to this bug.