Bug 560106 - Failed to install /lib/udev/firmware.sh
Summary: Failed to install /lib/udev/firmware.sh
Keywords:
Status: CLOSED DUPLICATE of bug 559597
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jason Carpenter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-29 20:56 UTC by John Reiser
Modified: 2010-01-30 18:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-30 18:38:05 UTC


Attachments (Terms of Use)

Description John Reiser 2010-01-29 20:56:14 UTC
Description of problem: yum update fails on kernel-2.6.33-0.24.rc5.git1.fc13.x86_64.


Version-Release number of selected component (if applicable):
kernel-2.6.33-0.24.rc5.git1.fc13.x86_64

How reproducible: once is enough


Steps to Reproduce:
1. yum update kernel-2.6.33-0.24.rc5.git1.fc13.x86_64
2.
3.
  
Actual results:
-----
  Installing     : kernel-.6.33-0.24.rc5.git1.fc13.x86_64
Non-fatal POSTIN scriptlet failure in rpm package kernel-2.6.33-0.24.rc5.git1.fc13.x86_64
E: Failed to install /lib/udev/firmware.sh
mkinitrd failed
warning: %post(kernel-2.6.33-0.24.rc5.git1.fc13.x86_64) scriptlet failed, exit status 1
-----
and indeed /boot contains no initramfs-2.6.33-0.24.rc5.git1.fc13.x86_64.img.


Expected results: successful update


Additional info:

Comment 1 Michal Jaegermann 2010-01-30 00:41:23 UTC
I got some "variation on the theme" albeit with the same result; i.e. no initramfs for a new kernel and no corresponding /etc/grub.conf entry. Here we go:

  Installing     : kernel-2.6.33-0.24.rc5.git1.fc13.x86_64                      77/158 
which: no multipath in (/sbin:/bin:/usr/sbin:/usr/bin)
E: Failed to install /lib/udev/firmware.sh
mkinitrd failed
warning: %post(kernel-2.6.33-0.24.rc5.git1.fc13.x86_64) scriptlet failed, exit status 1

No clue what that "multipath" is supposed to be or where this is coming from.
Neither package scripts nor /sbin/new-kernel-pkg nor /sbin/dracut seem to have
"multipath" string somewhere. /lib/udev/firmware.sh indeed is missing.  It looks like that this is caused by an update to udev-151-1.fc13.

Comment 2 Michal Jaegermann 2010-01-30 00:52:22 UTC
OK, /usr/share/dracut/modules.d/90multipath/install talks about /sbin/multipath
which somehow is nowhere to be found on my system.  Missing dependency?
'yum install /sbin/multipath' wants to grab device-mapper-multipath
and device-mapper-multipath-libs and libaio due to dependencies.

/usr/share/dracut/modules.d/95udev-rules/install wants to see missing /lib/udev/firmware.sh.  It looks like dracut out of sync with other updates
and mis-packaged in general.

Comment 3 Bruno Wolff III 2010-01-30 08:27:50 UTC
With dracut-004-5 I am now get usable updates. There was still a warning about a triggerin scriptlet failing when I reinstalled the kernels. But things seemed to still work.

Comment 4 Michal Jaegermann 2010-01-30 18:38:05 UTC

*** This bug has been marked as a duplicate of bug 559597 ***


Note You need to log in before you can comment on or make changes to this bug.