Bug 561216 - upstream bugfix for connection.py needs backporting
Summary: upstream bugfix for connection.py needs backporting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-boto
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 567698 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-03 02:57 UTC by Garrett Holmstrom
Modified: 2011-03-01 00:00 UTC (History)
5 users (show)

Fixed In Version: python-boto-1.9b-6.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-09 00:43:32 UTC


Attachments (Terms of Use)
Parameter fix (upstream bug #323) (3.39 KB, text/plain)
2010-02-03 02:57 UTC, Garrett Holmstrom
no flags Details

Description Garrett Holmstrom 2010-02-03 02:57:41 UTC
Created attachment 388421 [details]
Parameter fix (upstream bug #323)

Description of problem:
python-boto 1.9b requires a Name parameter for image registration when it doesn't need to, breaking euca2ools's calls to it.  Any chance we could see the fix from upstream patched into Fedora's package?

http://code.google.com/p/boto/source/detail?r=1448
http://code.google.com/p/boto/issues/detail?id=323


Version-Release number of selected component (if applicable):
python-boto-1.9b-1.fc12.noarch


Additional info:
A possible patch is attached.

Comment 1 Oliver Falk 2010-02-08 09:20:31 UTC
+1 to include this patch!

Comment 2 Robert Scheck 2010-02-09 00:43:32 UTC
Thanks for your report. The issue should be solved with 1.9b-2.

Comment 3 Fedora Update System 2010-02-09 00:54:02 UTC
python-boto-1.9b-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-boto-1.9b-2.fc11

Comment 4 Fedora Update System 2010-02-09 00:54:14 UTC
python-boto-1.9b-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-boto-1.9b-2.fc12

Comment 5 Robert Scheck 2010-02-23 17:08:33 UTC
*** Bug 567698 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-02-27 03:36:52 UTC
python-boto-1.9b-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-02-27 03:42:37 UTC
python-boto-1.9b-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-01-02 23:24:52 UTC
python-boto-1.9b-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-boto-1.9b-6.el5

Comment 9 Fedora Update System 2011-03-01 00:00:03 UTC
python-boto-1.9b-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.