Bug 5615 - 6.1 bootnet.img fails with python error during ftp upgrade
6.1 bootnet.img fails with python error during ftp upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-05 23:10 EDT by maynard
Modified: 2015-01-07 18:38 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 13:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maynard 1999-10-05 23:10:11 EDT
Multiple times I've tried an ftp updgrade (through the
infomagic mirror) and each time the upgrade has failed while
checking the rpm dependency database. I get a python
exception error (output looks like it's checking files
against the database) and then I'm afforded the opportunity
to reboot my computer or go into debug mode... unfortunately
I know nothing about python and can't help there.

This is repeatable... I can't upgrade redhat-6.1 at all. I'm
upgrading from a 6.0 box, which had been upgraded from 5.x,
and previous from that 4.x... so this box has seen numerous
upgrades over the years. Understand, this is an "Upgrade",
not a fresh install.
Comment 1 maynard 1999-10-05 23:20:59 EDT
Looking through some of the other bugs listed I wanted point out that
I only have three ext2 filesystems and a swap filesystem on this disk,
and am not using RAID. Also: No NTFS filesystems.
Comment 2 redhat 1999-10-06 05:09:59 EDT
This is the same as my submitted bug #5545.. And I hope it's resolved
soon :(
Comment 3 mamster 1999-10-07 12:16:59 EDT
I am getting the same error.  I do have three partitions, the last of
which is a Win98 FAT32 partition.  I repeatedly get this error after
about 55Mb of downloads - the Python installer hangs for a while and
then I get the error dialog.

My system is:
Intel Celeron 400MHz
256 MB RAM
13GB Seagate HD with Swap, Linux and Win98 partitions
NE2000 Compatible Ethernet

I was doing the RH6.0 -> 6.1 ftp upgrade
Comment 4 vrossum 1999-10-08 10:02:59 EDT
I had the same problem, but was able to work around it.
The rpm database of the 6.0 had some conficts.
I rebuild the datebase and removed a conflicting package (an old kde
version). (I don;t know an easy way to see what the conflicts are...)
After that the upgrade worked.

------- Additional Comments From   11/05/99 23:56 -------
A possible fix for this has been posted to linux.redhat.install and
comp.lang.python by pacman@defiant.cqc.com (Alan Curry) who claims
it's a behaviour change in wu-ftpd 2.6 interacting with a bug in
python1.5/urllib.py
Comment 5 Jay Turner 1999-12-02 11:00:59 EST
There are a couple of possible problems going on here.  One is that the server
name and the path to the source files for FTP installs must be specified in a
pretty specific format.  You must provide the FQDN or IP address for the server
and you must *NOT* put a trailing slash on the end of the path to the source
files.  Not doing the above will result in the error message quoted in 5545.

The other thing that could be happening is this problem that the person above
posted the fix to.
Comment 6 Jay Turner 2000-02-04 13:01:59 EST
Am closing out this bug, seeing as there has been no activity for a few months.

Note You need to log in before you can comment on or make changes to this bug.