Bug 56153 - Printing to HP LJ 5 is broken
Summary: Printing to HP LJ 5 is broken
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-13 13:46 UTC by Gerald Teschl
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 16:49:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-11-13 13:46:16 UTC
I tried to setup a hp lj 5l with printconf-gui. It dedected
the printer and I choose the default driver. But when
I tried to print a test page nothing happend. I searched all the
logs, debugged the perl scripts and eventually found out
that the config file "lj4dith-62720.foo" has a line

  'cmd' => ''

instead of the proper gs commandline and hence lpdomatic failes
"Cannot exec: ".

Next I tried to set it up as lj 4. Now the system produces some gs errors:

IF filter 'mf_wrapper' filter msg - 'cat: write error: Broken pipe' at
2001-11-13-14:33:14.634 ## A=root@ws10+376 number=376 process=8378
IF filter 'mf_wrapper' filter msg - 'Error: /ioerror in --.outputpage--' at
2001-11-13-14:33:14.721 ## A=root@ws10+376 number=376 process=8378
IF filter 'mf_wrapper' filter msg - 'Operand stack:' at
2001-11-13-14:33:14.721 ## A=root@ws10+376 number=376 process=8378
IF filter 'mf_wrapper' filter msg - '   1   true' at
2001-11-13-14:33:14.721 ## A=root@ws10+376 number=376 process=8378
IF filter 'mf_wrapper' filter msg - 'Execution stack:' at
2001-11-13-14:33:14.721 ## A=root@ws10+376 number=376 process=8378

Comment 1 Gerald Teschl 2001-11-13 14:02:31 UTC
I forgot to metion
1) printconf-0.3.52-1, ghostscript-6.51-16
2) These are the errors in /var/spool/lpd/lp/status.lp when printing the
a4-ps test page

Comment 2 Gerald Teschl 2001-11-13 14:03:41 UTC
The omni driver seems to work (at least the test page is printed).

Comment 3 Gerald Teschl 2001-11-14 17:03:01 UTC
Same problem with HP LJ1100: lj4 produces gs errors, omni works.

Comment 4 Tim Waugh 2002-01-10 11:22:47 UTC

*** This bug has been marked as a duplicate of 36720 ***

Comment 5 Tim Waugh 2002-01-23 16:48:26 UTC
Oh, this is with 7.2, but #36720 is with 7.1.  Looks like a different bug after
all.


Comment 6 Tim Waugh 2002-01-23 16:49:08 UTC
Do the packages at <ftp://people.redhat.com/twaugh/errata-candidate/> help?


Comment 7 Gerald Teschl 2002-02-12 14:07:39 UTC
Yes, the errate fixes the problem.


Note You need to log in before you can comment on or make changes to this bug.