Bug 56172 - Standard 7.2 on Athlon Duron won't boot
Standard 7.2 on Athlon Duron won't boot
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-13 11:30 EST by Larry Bruns
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-21 10:59:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Larry Bruns 2001-11-13 11:30:02 EST
Description of Problem:
Standard 7.2 installation on Athlon Duron won't boot.
Hangs forever during boot in a variety of places.
RedHat support told me to submit it to Bugzilla as a new bug.

Version-Release number of selected component (if applicable):
Standard 7.2 RedHat bought 3 weeks ago.
Installed on a brand new Athlon Duron box.

How Reproducible:
Tried installing it 3 ways.  All failed.  See details below.

Steps to Reproduce:
1. Standard 7.2 RedHat installation.  See below.

Actual Results:

Expected Results:

Additional Information:

Here is the email I sent Redhat support, and their response.
Service Request 194544 has been Updated

Incident Number: 194544
Customer Name:   LARRY BRUNS
Customer Number: 363774
Date Opened:     Nov 06, 2001 19:26
Date Changed:    Nov 09, 2001 06:27
Red Hat Tech:    Michael

Your Red Hat product:

Red Hat Linux 7.2 (RHF0044US)

Summary of your problem:

Boot fails after brand new install

Description of your problem:

7.2 installation repeatedly fails on a 1-month old PC (AMD Athlon/Duron
 1.2GHz chip on a "GigaByte" motherboard, 512MB RAM, 32KB Video RAM on a
 TNT2-M64/Vanta VGA card, MS "Natural" keyboard, Genica-2 scrolling mouse,
 RTL8139 Ethernet card).  7.1 works just fine on the same PC.

We tried this 3 different ways, and all failed :
1) Upgraded our previously customized 7.1 installation to 7.2.  (7.1 had
   been working fine for 1 mo.)
2) Re-installed a clean (i.e. reformatted hard disk), generic,
   uncustomized 7.1, followed by the 7.2 upgrade.  Before the 7.2 upgrade,
   the new 7.1 installation boots up fine and is fully functional.
3) Installed a clean (i.e. reformatted the hard disk again) copy of 7.2,
   as a virgin install instead of an upgrade.
All 3 scenarios fail to produce a bootable system!

Repeated reboots result in different errors virtually every time, but it
always ends up in a system hang somewhere.

Scenario (3) gives us these boot-time messages immediately after an
 apparently successful install :
............. [Note: before this point, many steps had completed with a
               green "OK" in the righthand column. Here's the last one: ]
............. Initializing USB controller ........................ OK
                [This is the last successful checkpoint before failure]
/etc/rc.sysinit: fork: Cannot allocate memory
free: called with unallocated block argument
stopping myself...Unable to handle kernel paging request at virtual
  address 000417c0
Oops: 0002
Process rc.sysinit(pid:165, .....................)

and, of course, it hangs the PC.
On subsequent reboots, a variety of other errors show up instead :
  -kernel panics
  -"respawning too fast"
  -kernel .... null dereference .....
And lots more.

Thank you for your help.
Larry Bruns

Our latest response:

Re: Appears to be a bug

Mr. Bruns,

Please open a bug report ticket for this call as this appears to be a bug
related issue. You may do this at:



michael karakashian

Status: Waiting on Customer


If you are having problems with our support services, please contact
sup-manager@redhat.com. If you are experiencing product registration
 problems, please contact register@redhat.com.

Thank you again for using Red Hat's Support Services!

Red Hat Support Team
Comment 1 Arjan van de Ven 2001-11-13 11:35:03 EST
Have you tried using the "noathlon" kernel option yet ?
(see bug 55040 or the release notes on how to do this)
It disables athlon specific optimisations; some bios versions for VIA chipsets
have a bug that causes such behavior...

Note You need to log in before you can comment on or make changes to this bug.