Bug 56177 - Clean up System List page
Clean up System List page
Status: CLOSED RAWHIDE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Devel
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Greg DeKoenigsberg
Jay Turner
:
: 56105 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 12:07 EST by Jay Turner
Modified: 2015-01-07 18:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-28 08:36:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2001-11-13 12:07:58 EST
Description of Problem:
Have a couple of issues to deal with on the
/network/systemlist/system_list.pxt page.  First, we need the real icons
which are going to be used on this page.  Second, for entitled servers, the
Errata count needs to be a link.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jay Turner 2001-11-14 08:11:46 EST
Don't know if this page is "done" yet, but a couple of things which I am seeing
on rhn.webdev and wanted to mention.  For profiles which have no errata, there's
a '0' count showing, but it's also being made a link.  So, just need to fix that
up.  The other thing is that I'm getting the gray '!' (errata available; update
recommended) for a machine which has no errata pending, just upgradable
packages.  Don't really know what we should label a machine in this state, as
there are no Red Hat errata pending against it, so technically it is up-to-date,
just doesn't have the latest packages on it.
Comment 2 Jay Turner 2001-11-14 14:10:38 EST
One other thing on this page.  The errata count is showing up as a link for
un-entitled servers and it should not be.  The Pkg counts are performing
correctly though :-)
Comment 3 Jay Turner 2001-11-15 21:54:51 EST
Still some cleanup necessary.  The errata count is still showing as a link for
un-entitled servers on rhn.webdev. And we need to figure out what we are doing
with the icons.
Comment 4 Jay Turner 2001-11-16 13:07:10 EST
*** Bug 56105 has been marked as a duplicate of this bug. ***
Comment 5 Jay Turner 2001-11-16 13:09:20 EST
Probably should also think about relabelling the entitlement levels which are
displayed.  Guess that we just need an icon to show if the system is entitled or
not.  No need for entitlement level.
Comment 6 Greg DeKoenigsberg 2001-11-28 08:36:15 EST
I believe that the page as it stands now is correct.  For now, we should call
the entitlement "Basic" with the tantalizing expectation that something beyond
"Basic" will be available very, very soon.
Comment 7 Jay Turner 2001-11-29 14:35:29 EST
This appears pretty good on rhn.webdev.  Only issue that I see is with the text
of the exclaimation point icon . . . already created another bug for this, so
closing this out.

Note You need to log in before you can comment on or make changes to this bug.