Bug 56185 - failed to open /etc/mtab for reading
Summary: failed to open /etc/mtab for reading
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 57317 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-13 18:09 UTC by Zing
Modified: 2007-04-18 16:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-04 10:05:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
check for null return from setmntent() (389 bytes, patch)
2001-11-13 18:10 UTC, Zing
no flags Details | Diff
drop last char of fulldirname if it is `/' when browsing through mtab otherwise /tmp would not be equal to /tmp/ (893 bytes, patch)
2001-12-14 01:36 UTC, Georgi Georgiev
no flags Details | Diff
sorry for the last patch..... this one is complete (918 bytes, patch)
2001-12-14 02:13 UTC, Georgi Georgiev
no flags Details | Diff

Description Zing 2001-11-13 18:09:25 UTC
Description of Problem:
tmpwatch complains "failed to open /etc/mtab for reading"

Version-Release number of selected component (if applicable):
tmpwatch-2.8-2

How Reproducible:
looks like you need an ext3 filesystem with a .journal file to reproduce 
this.

Steps to Reproduce:
1. /tmp is an ext3 filesystem with a .journal file
2. run "tmpwatch 240 /tmp"
3. get "failed to open /etc/mtab for reading"

Actual Results:
"failed to open /etc/mtab for reading"

Expected Results:
no error

Additional Information:
patch attached...

Comment 1 Zing 2001-11-13 18:10:44 UTC
Created attachment 37402 [details]
check for null return from setmntent()

Comment 2 Preston Brown 2001-11-28 22:22:11 UTC
fixed in 2.8.1 and later.  Shortly will be released as errata.


Comment 3 Aleksey Nogin 2001-12-11 17:46:48 UTC
*** Bug 57317 has been marked as a duplicate of this bug. ***

Comment 4 Georgi Georgiev 2001-12-14 01:36:15 UTC
Created attachment 40587 [details]
drop last char of fulldirname if it is `/' when browsing through mtab otherwise /tmp would not be equal to /tmp/

Comment 5 Georgi Georgiev 2001-12-14 02:13:28 UTC
Created attachment 40588 [details]
sorry for the last patch..... this one is complete

Comment 6 Ben Levenson 2002-01-16 19:47:04 UTC
Please download the errata RPMS from ftp://ftp.redhat.com.
(tmpwatch-2.8.1-1.i386.rpm) or 
update your system via Red Hat Network.


Note You need to log in before you can comment on or make changes to this bug.